Loaded project is unusable on Linux UE 4.7.1

Hello! There is an issue that I had encountered using UE Editor 4.7.1-0+++depot+UE4-Releases+4.7 on Kubuntu Linux 14.04.1.

I built the Editor accordigly to wiki article “Building_on_Linux” from sources downloaded from GitHub in archive. At the first startup Project Browser created a path to projects catalogue with a name consist of bunch of question marks, I’ve changed it to something regular.

The problem is that when I load created project with previously created and added content, the project is totally unusable. First of all, Unreal Project Browser says that I dont’t have any projects yet (maybe I should post separate report). Content Browser doesn’d see content, though files are exist in a filesystem. Controls in viewport: LMB doesn’t work, MMB works like RMB, RMB works like MMB.

Hey mageaster-

Do you run into the same issue on 4.7.3? Which repository are you cloning when downloading the engine? Let us know if you have any other information that would help us reproduce and test what you’re seeing.

Cheers

Doug Wilson

Hi Doug! Thanks for your answer! Yes, I have the same issue on 4.7.3 that I downloaded and built from official Epic github repository yesterday from scratch (removed 4.7.1). Actually I have no idea what exactly information could be useful.
OS is Kubuntu 14.04.1 x86_64, ext4 FS for root and /home, since I’m living in Russia, I use russian locale (no cyrillic in filepath or using roman simlinks). I tried to open a project from the Windows partition as mentioned [here][1] "- Note that some people have experienced a problem with the Editor not displaying anything in the Content Browser. One work-around is opening the Unreal Project from a case insensitive filesystem, such as a mounted fat volume on your system. " but this had no effect for me.
The problem with content browser and mouse control appears only after adding custom assets, saving the project and restarting the Editor.
Mouse control, to be exact, acts as following: LMB → move forward/backward, Alt+LMB → nothing; MMB&Alt+MMB → move up and down; RMB → nothing; Alt+RMB → zoom in/out.
[Here is][2] a simple project for example, I just removed the Starter Content in purpose of file to be not too large.
Let me know if you need any further, specifiс information.
Thanks again.
[1]: A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums
[2]: Google Drive: Sign-in

You mentioned the Building_on_Linux wiki page, when you do the “git clone…” step are you using “3dluvr” shown on the wiki page or do you substitute that with “EpicGames”? Additionally when adding custom assets are you referring to creating new assets in the editor such as a new blueprint or importing an asset from another program?

I do not do git clone, I download archive from Epic Games repository through web browser, unzip it and do the rest part of the instruction. I can try to do git clone if it is important. As to new assets - I import them from Blender 3D 2.71…2.74. Is it Static Mesh or Skeletal - no difference.
In addition, I found out that if I try to import the same object (Content Browser is empty, there even no Starter Content), the Editor says that this asset(s) already exists and asks whether I would like to replace it.
I can make some screenshots if needed.

Here is one more thing I have just mentioned: I’ve started a new blank project with Starter Content and there one thing slipped by in Konsole:

[2015.04.02-19.54.31:194][  0]LogPackageName:Error: DoesPackageExist: DoesPackageExist FAILED: 'StarterContent/StarterContent' is not a standard unreal filename or a long path name. Reason: Path should start with a '/'                                                
[2015.04.02-19.54.31:194][  0]LogPackageName:Error: DoesPackageExist: DoesPackageExist FAILED: 'StarterContent/StarterContent' is not a standard unreal filename or a long path name. Reason: Path should start with a '/'  

However Starter Content (a floor, chairs and a table) was added to the scene, only Architecture/Static Mesh “Floor_400x400” is displaying in the Content Browser.

Hah! I created a blank Blueprint Function Library, saved, restarted the Editor and all the rest of Starter Content appeared and created BFL as well!

One more test result. When I open the project with imported static mesh (and empty Content Browser) and open another Content Browser window, all content appears. Unfortunately, that doesn’t fix the problem with mouse controls.

Hey mageaster-

Testing the project you provided I noticed the behavior you received. However after creating a new project and importing a static mesh into it I saved the project then closed and reopened and did not have the same behavior. Additionally I migrated the cube asset from your project into a new project which did not break my content browser or mouse controls when opened either.

Is there a step other than importing a static mesh and then saving the project that I’m missing? Are you able to reproduce the behavior in a new project with the same cube asset or a new one? If so can you detail the steps taken to reproduce it?

Cheers

Doug Wilson

Hi. I made some tests and can systematize results step by step:

  1. Export from Blender 2.74. I tried many combinations - binary, ascii, with metric units, imperial units, without defined units, with and without UVs, a simpe cube and complex meshes. Here are some of them:
  2. Create a new project. Doesn’t matter whether it is blank or with game preset, with Starter Content or not. If create with SC, for the first time the Content Browser shows only Architecture/Static Mesh “Floor_400x400” Save and restart;
  3. Now all SC is shown in the CB. As it turned out, no creation of additional asset like blueprint is really needed. Import FBX (even no need to add it to the scene, just import with or without materials and textures). Save, restart;
  4. Get unusable project - empty CB, broken mouse controls. Opening of another window of the CB solves the problem of displaying of the content.
  5. Physical сopying of a file of the asset from the broken poject into a normal one looks like workaround.

Hey mageaster-

Sorry for the delayed response. Have you had the same problems with other versions of the engine? I have tried with 4.7.4 and 4.7.5 and have not had the issue you’ve described after importing assets, saving, and restarting the project. Additionally I’ve used the Import button in the content browser and choose “Import” rather than “Import All” during the import process.

Cheers

Doug Wilson

Hi, Doug! As I can see, my issue is not one of the simplest! I even had an idea to make a clone of my system into flashdrive and send it via delivery service >_<. I’m updating the Engine now, so I would be able to test the new version soon. I tried to use “Import” and “Import all” – the effect was identical. So, waiting for the new version to compile. Stay tuned.

I have built 4.7.5 and unfortunately still have the same problem.

Hello, Doug. After some tests with three different users with three different distros we have finally found out why you was not able to reproduce the problem. The fact is that I’m using locale ru_RU, and I experience the problem, but you are likely using en_US locale and can’t reproduce it. Since I have changed the locale into ru_US, the problem disappeared.

Hey mageaster-

Thanks for letting me know that you were able to find a solution. If switching from RU to US fixed the problem then it appears to be region specific as you suggested. I have submitted a bug report (UE-13931) for further investigation.

Cheers

Doug Wilson

Great! Thanks.

Hellow, Doug. I just have made a new disclosure on this bug. It appears even if I just open and close the Import dialog window and don’t actually import anything.

I have made some tests on version 4.8 and found out that projects created with 4.7.x still have this bug, but if I try to reproduce it in the totally new project, looks like all works fine! I’m happy!