Load Level Disables All Input

Hello all,

I’ve set up a menu that loads a level. When I preview the level by itself, everything works fine. When I load the menu and click the button that loads the level, my mouse and keyboard inputs no longer work. In fact, I can’t even hit Esc to exit the preview. I have tried Enable Inputs in both the menu and the level and that didn’t work.

Thank you!

You probably either set Input wrong or forgot to put it altogether. Please follow these guides and you should be good to go, if you still have issues, please attach screenshots so we can see your mistakes in the future, could be any number of million things! Thanks.

If this answered your question, please upvote and mark as answer so we can close this out properly. Good luck!

It works now, thanks for the awesome tutorials (enums look awesome, but way too complex to use in BP than it should)! I had followed another tutorial that shows how to interact with the menus without the extra initial click. That tutorial used Set InputMode UIOnly and I changed it to Set InputMode Game and UI.

Thank you!

So I wasn’t of any help at all ? :frowning: Booo :wink: But awesome you got it working!

Please choose the answer so we can close this out appropriately, good luck!

Not directly, but I started to learn about enums, but they don’t look BP-friendly.