Load asset from .pak file


I’m trying to load asset from .pak file, this pak have :

  • A Texture
  • A SkeletalMesh
  • A Skeleton
  • A PhysicsAsset

This is my project folder tree:

MyProject/Content/ :

  • PAK/ (contain “2286.pak”)
  • UNPAK/

So I’m loading the .pak at runtime in the UNPAK/ folder but i’m not able to LOAD these assets to use them after…I tried different things to load them but every time I got errors like “File not found”.

Here is the function and the output logs… I think they’re not “loaded” properly 'cause when I put these assets into an other folder, save the project, quit and come back I can use “EngineUtils::FindOrLoadAssetsByPath” and it work… I think they’re “cook”.

What I really want is load a pak file and use the assets at runtime…

If someone have an idea on why it doesn’t work… I will be really happy :smiley:



I also tried this method:

It’s supposed to work but not really …

Adding an ‘answer’ to own question make it only worse. Since people will see that it’s have one answer already. Also it won’t pop up in ‘unanswered’ list.

I don’t think it’s not possible to do it ! Please someone can help me?

I found the solution … I was just not on the right process. I am currently stocking my .uasset in a .zip that I download and that I unzip directly into the project. I then use these assets to construct my character.

I use this plugin to unzip my files :

how do you download the zip files?

@nyudeb what is the solution? I have spent days on this

I know this is a old post, but… I really need to know how to load assets of a pak file but the assets is cooked I think… please help me!