Download

LiveLinkXR/OpenXR in 4.26, has anyone got it working???

I’ve been trying to get LiveLink XR/OpenXR to work for bringing in VIVE tracker data but I’m having no luck. Everything I try results in me seeing “no data” in the livelink window. Has anyone got this working? I’m probably missing some simple setup step. I want to test using VIVE trackers through LiveLink to see what advantage it has over MotionController components.

I had the same problem, try disabling the openXR plug-in and only use the LiveLinkXR plug-in. It looks like there’s an incompatibility with the two of plug-ins. I have it working with liveLink from maya (although for some reason it doesn’t work inside the virtualCameraPlayerController input source). I’m using SteamVR 1.14.16 and 4.26 Preview2.

image.png

LiveLinkXR works for me in a clean project but as soon as I enable nDisplay, tracking drops out. Anyone else able to get both working together?

I haven’t tried it yet but Aiden Wilson has it working with 4.26 in a Youtube video https://youtu.be/UexGZ08goEU

Do the Vive trackers work on their own with OpenXR without Livelink btw?

Has anyone made any progress on this with nDisplay? SteamVR plugin enabled, get things looking ok in editor, launch via nDisplay, crash. Disable plugin, nDisplay no longer crashes, but has no tracking. 4.26, same circles.

Similar issue here. I can’t even enable my steamVR button in the official In Camera VFX template they provided. And in the livelinkXR tab, I can’t receive data, in the meantime I can get the data in other blank projects. Does anyone know what’s special about the In Camera VFX template? I really want to use the already provided stuff in the template, but no luck.

In 4.25 nDisplay only worked via nDisplays in-editor mode, when using SteamVR. Runing nDisplay in in-editor mode, also makes your workflow somehow smoother, and faster.

Also have you tried enabling the “Livelink over nDisplay” plugin, when using livelinkXR?

I follow every step from the InCamera VFX document.
Also, Aiden Wilson’s tutorial doesn’t involve Ndisplay.

I noticed in the document,ther is a “In the nDisplay launcher, add -messaging to the custom command line arguments.”
I wonder if there is anything I didn’t quite get right here. Do you just and -messaging in the command line in the nDisplay Launcher? Or is there any other thing to be done to get it working?

Any config or Button I missed, please enlighten me! I have been struggling with this issue for 2 weeks with no luck.

I haven’t actually tried using LivelinkXR+nDisplay yet. I have only used Vive trackers and nDisplay over VRPN.
Found out most input sources did not work, when using nDisplay, unless I used VRPN. Probably because if you are running nDisplay with multiple rendering nodes the input needs to be distributed to all the nodes.
I will try this In-Camera VFX Quick Start | Unreal Engine Documentation
tonight and report back

I wasn’t able to get LiveLinkXR to recognize my Vive tracker till I switched computers and then suddenly it was recognized. It could also have something to do with physically plugging in the tracker.
Over all it’s been super simple and great but I’m having an issue where whenever I begin my simulation the camera snaps back to a specific position on the map. Any ideas how to fix this? Also if anyone else is super new to this process like I am DO NOT turn off the NDisplay plugin. I did and I wasn’t able to open my entire project till I turned it back on using the notepad function to turn on plugins before opening the project.

Guys, I have figured out that nDisplay doesn’t work with livelink XR,the only way I managed to get it working is through the VRPN. I think it may be because when tracking position, the tracker has to send message to multiply PCs at the same time.

Also, the doc says using livelink(which is not livelink XR), however if you want to use livelink, like motion builder, you still can’t get the vive to send data into motion builder.

I think the easiest way to use VRPN.