Live Link VCam - Couldn't Connect


I would like to say in advance, I have searched and tried very long and intensively before writing this post.

I bought an iPad just to use it with Live Link.

I followed every step in the documentation, I tried different Unreal versions, I revised my firewall exceptions and followed instructions in forums of people with similar problems. Nothing has helped.

I just always get this message, I’m getting desperate. Why the hell can’t I get a connection with Live Link Vcam? Can someone give me a push in the right direction? What else can I try? My network is set to private, my devices are all connected in the network either via wifi or lan, my iPad Pro is 2nd generation (2020) and ARKit capable, is brand new and virtually in factory condition.

Thank you.

BTW: Answerhub Post: Live Link VCam - Couldn’t Connect - AnswerHub - Unreal Engine Forums

1 Like

I have a similar problem, still, I think I can provide a bit more information.

I figure out that there are two different errors messages.

  1. “attempt to connect timeout” should mean that your iOS device is not able to find the Unreal PC
    I had problems with my firewalls and had to disable them.
    A good way to test this is to check if you can ping the iOS device, and vice versa (for this you probably need to install some net focus app).

  2. the second message I get is “connection refused”, which seems to suggest that the connection discovery (ip+port) was successful, but the UE4 refused the connection. This is where I am stuck.
    This is pure speculation from this point onwards, but either the protocol is not being respected and UE4 just flat out discards the communication, or the UDP starts as a discovery protocol that passes the communication to a TCP channel, and something goes wrong there.
    I hope, that this is just on my side and at least you can figure out a solution on your end.

Meanwhile, if someone else has suggestions on how to go from here I would highly appreciate it.

I am not sure if this helps.

  1. I am not a network pro. but the network guy made sure my ip’s 3rd number on the iOS device and the desktop were in the same IP region
    so example 192.168.20.XXX for both devices. instead fo 192.168.XXX.YYY where X and Y varies each way.

Hope this helps?

  1. In my weird situation. I had to run UnRemote first for the live link window source to identify and hookup then swap to LiveLinkVcam to get the desktop to read the vcam app as a source.

I just can’t connect the App to the PC: every time is a “Couldn’t connect: Attempt to connect to host timed out”.
IPs are correct, Windows Firewall is down and the source is seen by the Live Link window in Unreal.

The same thing happens to me, however, when I press play the application connects, although I cannot assign subjects to the vlink. thx

Yes, VCAM support is still buggy unfortunately. It used to be more reliable. Not sure if ios15 changes or Unreal changes. I managed to connect with iPhone, same address, connected to live link, and then dropped. iPad not able to connect with all the standard settings I had been using.

1 Like

hi, had the same issues on ue5ea but I’ve tried following these steps from a reviewer on the app’s page and it connects (unfortunately the last step makes the editor crash so no camera transform so far, will try on 4.27):

Here’s how it works

Follow these steps closely.

  1. In your Unreal Scene (4.26 or Higher; 4.27 recommended), make sure you’ve setup your Static Endpoints under “Project Settings” → “UDP Messaging”. You should have the IP of your PC as well as the IP of your iOS device. They need to be on the same subnet to work properly!

    1. Add a VirtualCamera2 Actor to your scene.

    2. In the VirtualCamera2Actor properties, select the VCAM (Inhereited) from the components tree.

    3. Under “Virtual Camera” check “Enabled”

    4. In the “Output Providers” rollout, under “0” → “Output”; Check the “Is Active” toggle

    5. On your iPad/iPhone launch the Live Link VCAM app BUT DO NOT CLICK CONNECT! (When the app is open it sends a signal to your PC waiting to connect)

    6. In UE, in the Live Link window, click “+ Source”. Your iOS device should show up now as a VCAM source. (NOTE: If you hit connect on your iPad before this step, you didn’t read #6 carefully enough.)

    7. At this point you should: VCAM and Is Active Enabled, your iOS device active in your LiveLink Window, your iPad app still on the Home Screen (magenta with Connect Button).

    8. Hit Connect

    9. Lastly, under the VCAM Properties there is a “Live Link Subject” drop-down. Select your iOS device from this drop down and everything should start talking to each other; VCAM UI showing on both Project and iOS device as well as telemetry data.

    Hope this helps!

edit: can confirm it works flawlessly so far on 4.27; ue5ea also has some app UI issues but will most likely be fixed by full release


Oh, thank you!!! I’ve been tormented all day trying to establish a connection, but only your method worked for me! UE5

Thank you! Thank you! Thank you! Thank you!

One small addendum. If after doing this Livelink does NOT see your iDevice try adding :6666 to your Static IP endpoint in your Project Settings> UDP Messaging
So that means you would have 2 Static endpoints both with :6666 added.

All settings are checked 100 times. not working
it shows iPhone in the source. but iPhone never connects. always says" timed out".
I am using iPhone 12 mini and UE5.
Please help

Thank you so much for the rundown ! It works flawlessly with UE5 and iPhone 12.

The only thing I was actually missing for this to work was to Play the Unreal Engine Level. Are you all runing the camera like that or expecting a behaviour as in regular live liink tracking?

this process isn’t working for me consistently, and this is reflective of the quality of the development Epic has done. I had a vcam working on my project one night, I left and came back and changed nothing, double checked that the ip addresses didnt change when I came back, and it was timing out on the app and couldnt connect. Why? Same project, same IP addresses, unchanged project settings. Doesn’t work.
Judging by how many folks are having the same issue, this is a broader issue than just “make sure you add :6666” somwhere.


WOW. This is exactly what should be in the Manual!!! Maybe Epic should be flagged, cause after 2 hours of clicking and playing with windows, I found your post and in 15 seconds was working.

Hi everyone I founded other settings for connection. If you did everything correctly in documentation and If it’s not working anyway you can try:

  1. In your Vcam app settings choose remote.(It’s normally pixel streaming.)
    2)Choose private connection in wifi settings from your Ipad.
    3)Choose private connection in wifi settings from your computer.
    4)Try again first instructions.
    I hope it’s works for you Good Luck…
1 Like

Did everything step by step as per your instructions, but I couldn’t find my iPhone in the Message Bus Source. In Step no. 1 you mention that one should have both IP of PC as well as IP of the iOS device. Am I correct in understanding that the Unicast Endpoint under UDP Messaging should have the IP of the PC, the Multicast Endpoint should be left alone? Then where does the IP of the iOS Device go?

I’m wondering the same. Assuming it is added as the static endpoint but un clear and still blocked

Thanks, it worked :slight_smile:

No, still cannot connect at all. Connection refused. 5.1.1 on Ventura 13.3 and iOS 16.4.