Download

Live Link VCam - Couldn't Connect

Hello,

I would like to say in advance, I have searched and tried very long and intensively before writing this post.

I bought an iPad just to use it with Live Link.

I followed every step in the documentation, I tried different Unreal versions, I revised my firewall exceptions and followed instructions in forums of people with similar problems. Nothing has helped.

I just always get this message, I’m getting desperate. Why the hell can’t I get a connection with Live Link Vcam? Can someone give me a push in the right direction? What else can I try? My network is set to private, my devices are all connected in the network either via wifi or lan, my iPad Pro is 2nd generation (2020) and ARKit capable, is brand new and virtually in factory condition.

Thank you.

BTW: Answerhub Post: Live Link VCam - Couldn’t Connect - UE4 AnswerHub

I have a similar problem, still, I think I can provide a bit more information.

I figure out that there are two different errors messages.

  1. “attempt to connect timeout” should mean that your iOS device is not able to find the Unreal PC
    I had problems with my firewalls and had to disable them.
    A good way to test this is to check if you can ping the iOS device, and vice versa (for this you probably need to install some net focus app).

  2. the second message I get is “connection refused”, which seems to suggest that the connection discovery (ip+port) was successful, but the UE4 refused the connection. This is where I am stuck.
    This is pure speculation from this point onwards, but either the protocol is not being respected and UE4 just flat out discards the communication, or the UDP starts as a discovery protocol that passes the communication to a TCP channel, and something goes wrong there.
    I hope, that this is just on my side and at least you can figure out a solution on your end.

Meanwhile, if someone else has suggestions on how to go from here I would highly appreciate it.