Live editor plugin has broken my blueprints

Hi, at some earlier point in my project I enabled the live editor plugin for a few (unsuccessful) experiments. Now though all of my blueprints are somehow tainted by this action.

Now my project (in 4.8.3) won’t compile or run standalone. If I disable the live plugin the editor crashes (if it’s loading a map with any of my blueprints in)

If I load a blank map and drop ANY of my blueprints onto it it will crash the editor.

I’ve cleaned my blueprints as much as I can - there are no events or funny variables which reference anything strange. None the less, all of my blueprints seem somehow tainted by the live editor.

It all works normally if I re-enable the live editor plugin but, like I said, it won’t build or even run standalone.

(I’ve tried copying my content folder to a new project)

Thanks in advance!

Sorry, when I said build I meant package. I can make the Win64 package but if i run it it crashes. I don’t seem to have any information in the crash report.

Hello ,

What type of errors are you getting when you attempt to build (I assume you mean the build button in the editor, and not compiling?) or run the game in standalone? Can you post the callstack from the crash you get when trying to open the project without the plugin? Does this only happen as of 4.8.3 or did it also occur in 4.7?

Ok - the crash report is too long to post.

I’ve tried migrating to 4.9 with the same problems - this is a crash report from me trying to run the game standalone from the editor.

That’s a link to the diagnostics.txt file which contains everything I think.

Thanks so much for the help and please let me know how you debugged it too!

Hello ,

When you mention that you tried migrating to 4.9, do you mean that you switched the engine version on the project? If this is the case, can you try creating a new project in 4.9 and migrating the content over to be sure that it’s not a conversion issue? Be sure to use the migrate option in the editor under ‘Asset Actions’ when right-clicking an asset. Copying the content folder over can cause issues with references among other things. The reason I stress this is that I’ve found a bug report that seems similar to this issue that was fixed in 4.9.

Hello ,

We haven’t heard from you in a while. Are you still experiencing this issue or was my previous answer of any help? In the meantime, I’ll be marking this issue as resolved for tracking purposes.

Hi - Sorry for the radio silence. I realised what the problem was. I migrated the assets I was using (there was a lot of junk in the project, and I didn’t realise how cleverly the migration tool works) Then - with my simplified game project - I was able to track down a single variable in a blueprint which referenced a long deleted Live Edit blueprint. When I cleared that everything worked.

I must say though - although i’ve never got it to work, i’m intrigued by Live Edit - i use UE to create tv show style quiz game prototypes which I drive (laboriously) from an iPad (using OSC) into a python script, which then sends commands to UE through a TCP listener. I’d love an easy way into the engine from outside.

Thanks for the help!