Download

Listen Server on iOS

Has anyone had any success in using a listen server for multiplayer on iOS? I’m able to get a client to see and join a server session (using two phones), but the client does not load the game map - just stays on the main menu map. Works fine in standalone mode with two players from the editor, but not on my iPhones.

i had the same issue. The reason was that the join session function uses for network connections the IP6 format.
But due to my router settings it only worked with IP4 addresses. Some routers use ip4/ip6 conversion. It might be related to this, but not sure.
(example IP4 format:192.168.178.69 / IP6 format: 2001:0db8:0000:0000:0000:ff00:0042:7879)

Instead of using the join session function, i used the console command (4-finger tap or blueprint node): open [listen server’s ip4 address]
that worked. you could give it a try, good luck

also in DefaultEngine.ini :
[OnlineSubsystem]
DefaultPlatformService=Null

That worked! Thanks so much - I was about to give up on LAN play for the iPhone. Just one more thing - I hard-coded one of my phones ip address in the open] call just to test, because I couldn’t see a way to get it in the response from the Find Session (actually Find Session Advanced) node. Is there a way to get the server’s ip address in blueprints so I can append it to the Extra Settings when I call Create Advanced Session?

I created a C++ blueprint library that exports a function that uses GetLocalHostAddr to get the local ip uses ToString on it to return the ip, but unfortunately it is also IPV6.

yeah, don’t know either how to deal with this issue. any ip4 can be converted to ip6, but not the other way for all ip6 (more bits than ift in ip4 format).
Epic should fix this in their code, but in my experience they won’t do anything about it unless Fortnite needs it.