[Linux] Viewport not filling entire screen in Fullscreen mode if non-native Resolution

Hey guys,

Currently in the standalone executable if I set the window to full-screen mode with a non-native resolution, (e.g. “r.SetRes 1024x768f” on a 1920x1080 monitor) the viewport only fills the screen of the set resolution instead of stretching to cover the entire screen. (i.e. it always keeps a 1:1 ratio of viewport to set Resolution.)

Is this the intended behavior? or should (like in windows) the Viewport stretch to cover the screen?

I’m currently running the game on Ubuntu 14.04 LTS, and I am also seeing this issue on SteamOS.

Cheers.

Hey FacePalm.exe-

I was able to reproduce this and have entered a bug report for investigation (UE-19996).

Cheers

Doug Wilson

Hi, I also have this issue on Windows 10 64b pro

Is there a timeline for a fix ?

Hey Gwenn-

I’ve looked into the reported bug and saw that it is still under active assessment by our development staff. Unfortunately there is currently no timeframe for when a fix will be released.

Cheers

Doug Wilson

Hey Doug,

We’re still waiting on this as well to ship a linux version of our shipped title.

Is this a “We’ll get to it when we get to it” type of bug? i.e. It’s probably never going to be fixed unless someone else does it?

Cheers.

Hey FacePalm.exe-

We have increased the priority of the issue with a target of fixing it for the 4.13 release. If you are still seeing this issue after the release of 4.13 let us know and we will re-investigate.

4.13 contains a fix for this, which makes Fullscreen fully identical to WindowedFullscreen: https://github.com/EpicGames/UnrealEngine/commit/5fe44a6d9626239723fd306b25fb6843708d7348

With that fix, you should not experience window not being stretched, however, your game’s resolution in fullscreen will always match desktop resolution.

If that is not desired, there are two ways:
a) Set r.ScreenPercentage to a smaller value whenever fullscreen mode is enabled
b) Undo the abovementioned fix and change LinuxWindow.cpp to switch to real fullscreen, and not windowed one.

I advise against the latter, since we had a lot of problems with that approach due to limitations of Linux graphics stack, e.g. resolution will not be switched back if the game crashes or on resolution change you can end up with unusable machine that will require restart of X.