[Linux][UE5] UnrealEdit crashes on startup


I’v just built the new an shiny UE5 Editor on my Linux machine and getting a crash during startup.

Unreal.log: http://dpaste.com/4XJAKRH4C
Diagnostics.txt: http://dpaste.com/8Z55T549A
CrashReportClient.ini: http://dpaste.com/CKVLFTZXG

Any help is appreciated.


Did you get anywhere with this?

Same problem here. Linux Mint running Ubuntu 20.04 with stock AMD drivers (tried the amdgpu-install script and got nowhere) with R9 280X 3GB video card , dual Xeon with 32 gig of ram and it just falls over loading the editor.

Not very familiar with Unreal but seems to fail creating texture instance so out of texture memory maybe? IDK.

Assertion failed: EnumHasAnyFlags(UEFlags, ETextureCreateFlags::UAV) [File:./Runtime/VulkanRHI/Private/VulkanTexture.cpp] [Line: 446]

libUnrealEditor-VulkanRHI.so!FVulkanSurface::GenerateImageCreateInfo(FVulkanSurface::FImageCreateInfo&, FVulkanDevice&, VkImageViewType, EPixelFormat, unsigned int, unsigned int, unsigned int, unsigned int, unsigned int, unsigned int, ETextureCreateFlags, VkFormat*, VkFormat*, bool) [/media/ue_work/UnrealEngine/Engine/Source/./Runtime/VulkanRHI/Private/VulkanTexture.cpp:446]
libUnrealEditor-VulkanRHI.so!FindOrCalculateTexturePlatformSize(FVulkanDevice*, VkImageViewType, unsigned int, unsigned int, unsigned int, unsigned int, unsigned char, unsigned int, unsigned int, ETextureCreateFlags) [/media/ue_work/UnrealEngine/Engine/Source/./Runtime/VulkanRHI/Private/VulkanTexture.cpp:2574]
libUnrealEditor-VulkanRHI.so!FVulkanDynamicRHI::RHICalcTexture2DPlatformSize(unsigned int, unsigned int, unsigned char, unsigned int, unsigned int, ETextureCreateFlags, FRHIResourceCreateInfo const&, unsigned int&) [/media/ue_work/UnrealEngine/Engine/Source/./Runtime/VulkanRHI/Private/VulkanTexture.cpp:2594]
libUnrealEditor-Engine.so!FTexture2DResource::GetPlatformMipsSize(unsigned int) const [/media/ue_work/UnrealEngine/Engine/Source/./Runtime/Engine/Private/Rendering/Texture2DResource.cpp:186]
libUnrealEditor-Engine.so!FStreamableTextureResource::InitRHI() [/media/ue_work/UnrealEngine/Engine/Source/./Runtime/Engine/Private/Rendering/StreamableTextureResource.cpp:169]
libUnrealEditor-RenderCore.so!FRenderResource::InitResource() [/media/ue_work/UnrealEngine/Engine/Source/./Runtime/RenderCore/Private/RenderResource.cpp:120]
libUnrealEditor-RenderCore.so!TEnqueueUniqueRenderCommandType<BeginInitResource(FRenderResource*)::InitCommandName, BeginInitResource(FRenderResource*)::$_160>::DoTask(ENamedThreads::Type, TRefCountPtr<FGraphEvent> const&) [/media/ue_work/UnrealEngine/Engine/Source/Runtime/RenderCore/Public/RenderingThread.h:193]
libUnrealEditor-RenderCore.so!TGraphTask<TEnqueueUniqueRenderCommandType<BeginInitResource(FRenderResource*)::InitCommandName, BeginInitResource(FRenderResource*)::$_160> >::ExecuteTask(TArray<FBaseGraphTask*, TSizedDefaultAllocator<32> >&, ENamedThreads::Type, bool) [/media/ue_work/UnrealEngine/Engine/Source/Runtime/Core/Public/Async/TaskGraphInterfaces.h:975]
libUnrealEditor-Core.so!FNamedTaskThread::ProcessTasksNamedThread(int, bool) [/media/ue_work/UnrealEngine/Engine/Source/./Runtime/Core/Private/Async/TaskGraph.cpp:753]
libUnrealEditor-Core.so!FNamedTaskThread::ProcessTasksUntilQuit(int) [/media/ue_work/UnrealEngine/Engine/Source/./Runtime/Core/Private/Async/TaskGraph.cpp:641]
libUnrealEditor-Core.so!FTaskGraphCompatibilityImplementation::ProcessThreadUntilRequestReturn(ENamedThreads::Type) [/media/ue_work/UnrealEngine/Engine/Source/./Runtime/Core/Private/Async/TaskGraph.cpp:2114]
libUnrealEditor-RenderCore.so!RenderingThreadMain(FEvent*) [/media/ue_work/UnrealEngine/Engine/Source/./Runtime/RenderCore/Private/RenderingThread.cpp:380]
libUnrealEditor-RenderCore.so!FRenderingThread::Run() [/media/ue_work/UnrealEngine/Engine/Source/./Runtime/RenderCore/Private/RenderingThread.cpp:544]
libUnrealEditor-Core.so!FRunnableThreadPThread::Run() [/media/ue_work/UnrealEngine/Engine/Source/./Runtime/Core/Private/HAL/PThreadRunnableThread.cpp:25]
libUnrealEditor-Core.so!FRunnableThreadPThread::_ThreadProc(void*) [/media/ue_work/UnrealEngine/Engine/Source/Runtime/Core/Private/HAL/PThreadRunnableThread.h:185]

I’ve fixed my problem seems to be not allocating VRAM correctly in the driver and possibly not enabling the amdgpu driver correctly so this is explicit. Can’t see your logs but I’m going to suspect it’s similar:

sudo xed /etc/default/grub

Change this line to include the following. I have 32gb so went crazy and put in 8gb pool from main memory. I also changed the visible VRAM from CPU size to 1024 dunno if this actually did anything but figured it might improve performance:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash amdgpu.cik_support=1 amdgpu.gttsize=8192 amdgpu.vis_vramlimit=1024 amdgpu.gartsize=8192 amdgpu.si_support=1 radeon.si_support=0 radeon.cik_support=0"

then run:

sudo update-grub 

And reboot.

This should force amdgpu driver to be used - source - I’m not sure if the memory pool changes were needed but seemed like a good idea as my error looked like an unhandled out of memory problem: Enable AMDGPU Linux Driver in Debian Ubuntu mint - rtt - IT Resource

Also, I don’t know if this is actually needed but I tweaked the following file based on the linked article:

sudo xed /usr/share/X11/xorg.conf.d/10-amdgpu.conf

With the following from the linked page, I can’t be bothered to test all the variations I just know it loaded OK with these settings :slight_smile:

Section "OutputClass"
    Identifier "AMDgpu"
    MatchDriver "amdgpu"
    Driver "amdgpu"

Section "Device"
    Identifier "Card0"
    Driver "amdgpu"
    Option "TearFree" "on"
    Option "DRI3" "1"

Take care to ensure that file is EXACT otherwise your startx will fail and you’ll be dumped to a terminal.

Hope this helps, I just wish AMD would actually provide some kind of test environment perhaps with a small OpenGL / Vulkan demo which can be used to test everything is set up correctly and perhaps all you to tweak these parameters but I guess they just like us to guess these things.

Also would be nice if Unreal actually handled this exception corrected and said “hey you’re out of VRAM please go check if your drivers are correctly configured I need X megabytes minimum” but hey ho.

When all of this is done I get the following on the console output in UnrealEditor:

[2022.07.13-17.30.57:867][  0]LogVulkanRHI: Display: 3 Device Memory Heaps:
[2022.07.13-17.30.57:867][  0]LogVulkanRHI: Display:   0: Flags 0x1 - Size 2952790016 (2816.00 MB) - Used 0 (0.00%) - DeviceLocal - PrimaryHeap
[2022.07.13-17.30.57:867][  0]LogVulkanRHI: Display:   1: Flags 0x0 - Size 8589934592 (8192.00 MB) - Used 0 (0.00%)
[2022.07.13-17.30.57:867][  0]LogVulkanRHI: Display:   2: Flags 0x1 - Size 268435456 (256.00 MB) - Used 0 (0.00%) - DeviceLocal
[2022.07.13-17.30.57:867][  0]LogVulkanRHI: Display: 4 Device Memory Types (Not unified):
[2022.07.13-17.30.57:867][  0]LogVulkanRHI: Display:   0: Flags 0x00001 - Heap  0 -  DeviceLocal                                         
[2022.07.13-17.30.57:867][  0]LogVulkanRHI: Display:   1: Flags 0x00006 - Heap  1 -              HostVisible HostCoherent                
[2022.07.13-17.30.57:867][  0]LogVulkanRHI: Display:   3: Flags 0x0000e - Heap  1 -              HostVisible HostCoherent HostCached     
[2022.07.13-17.30.57:867][  0]LogVulkanRHI: Display:   2: Flags 0x00007 - Heap  2 -  DeviceLocal HostVisible HostCoherent                
[2022.07.13-17.30.57:867][  0]LogVulkanRHI: Display: Memory Budget Extension:
[2022.07.13-17.30.57:867][  0]LogVulkanRHI: Display: 	         | Usage                      | Budget           | Size             |
[2022.07.13-17.30.57:867][  0]LogVulkanRHI: Display: 	---------|------------------------------------------------------------------|
[2022.07.13-17.30.57:867][  0]LogVulkanRHI: Display: 	 HEAP 00 |   0.00% /          0.00 MB |       2152.07 MB |       2816.00 MB |
[2022.07.13-17.30.57:867][  0]LogVulkanRHI: Display: 	 HEAP 01 |   0.00% /          0.00 MB |       8125.98 MB |       8192.00 MB |
[2022.07.13-17.30.57:867][  0]LogVulkanRHI: Display: 	 HEAP 02 |   0.10% /          0.25 MB |        198.02 MB |        256.00 MB |
[2022.07.13-17.30.57:867][  0]LogVulkanRHI: Display: 	---------|------------------------------------------------------------------|

So possibly ignored the 1024 but the rest looks good and didn’t appear before.

Update: just upgraded to an nVidia card and no issues… so if you can’t be bothered fighting shoddy drivers buy an nVidia :slight_smile:

HI,I had the same problem, but I was on an nvidia graphics card.
advRootMotion_multiplayer.log (48.4 KB)

Hi, I have same problem but I using Intel integrated graphics (UE4 works normally)

I found problem. Version, which wasn’t work was 5.1.1. Version 5.0.3 loaded sucesfully