Linux server build with OnlineSubSystemSteam crashs on 4.17.2


After moving from 4.16.3 to 4.17.2 my linux server build will crash with the following message every time I launch it on my Debian 4.9.0-3 machine:

Fatal error:
[Line: 1082] FMallocBinned2 Attempt to
realloc an unrecognized block
0x7fc81c0e0000 canary == 0x3 != 0xe3
Signal 11 caught. Malloc Size=131076
CommonLinuxCrashHandler: Signal=11
Malloc Size=65535
LargeMemoryPoolOffset=196655 Engine
crash handling finished; re-raising
signal 11 for the default handler.
Good bye. Segmentation fault (core

I’m building my server on tag/4.17.2-release with clang 4.0 downloaded from the 'Building On Linux" wiki page and I’m using the OnlineSubSystemSteam plugin.

Can anybody confirm if this is a bug to be fixed or I’m missing something that need to be tweaked before moving to 4.17?


Could you paste the whole callstack (If it’s not in the log, then could you please get it from under gdb)? This resembles a problem with Steam that we had to work around in the past (but we removed workaround in 4.17 since it gets into way of other things).

After update steamcmd on my linux machine the my server build no longer crashs (the didn’t seems get updated and already at the latest version thou, which is weird since I thought that’s the only file matters to the serer build). Sorry I could no longer provide the callstack since everything works right now and I don’t want make it crash again.

Thanks! We worked with Valve to resolve that issue in the past, so I’m glad that it’s worked as intended :slight_smile: