Download

Linux packaging fails during cooking phase (Cross-compilation from Windows) UE4 V4.26

Hi all. I am kind of desperate already about this thing. I have been trying to build the engine for Linux 64bit on Windows and it always fails during the cooking.
I did the whole setup according to the manual:

  1. Built the engine from the source
  2. Downloaded and installed Clang toolchain for 4.26 from Epic.

Created an empty scene (downgraded just to make sure there are no issues related to assets) with one cube + texture material on it + dir light.

The compilation part goes okay.
Then there is a failure during the cooking phase. In the beginning I was getting errors related to Shader maps compilation for assets which are part of the engine content. Removed all those from the map and now I can’t even understand the reason for the failure. I am getting this:

Here is the related part from the Log file:

I am currently have no clue what it can be. Need help.Thanks!

I had the exact same problem in the same setting (building for Linux 64bit using UE4 4.26.1 on Windows), even when packing an empty project. I even tried using the engine built from the source code (it’s not really necessary for UE4.26.1, just install the Clang toolchain and reboot), but no success (hours wasted for nothing). I decided to build to Linux (the option that is not Aarch64) using the Epic Games Launcher engine 4.26.1 version and it worked perfectly fine! I guess it’s a bug from the engine. I didn’t have enough patience to test older engine versions tho.