Linux not available as a platform to build for

I’m totally new to UE and game development, so not sure if I’m asking a stupid question.

Thus far I’ve made a multiplayer game that I managed to build for windows as dedicated server and client builds. And all works well (well, after 2 days of compiling UE from source, getting my blueprint project to be able to be used as Visual Studio project for a dedicated server and bunch of stuff)

I’m trying to cross-compile the server part for Linux, as I already own some Linux servers to test it there and eventually host it(?)

UE is 5.0.3

I’ve installed toolchain v20_clang-13.0.1-centos7, yet my UE says that Linux is still under platforms that have no compiled support. I have NOT added any flags, such as -exclude=Linux when I run Setup.bat during the UE from source installation.

How do I go about building my server for linux?

Come on people… :frowning:

After installing the correct cross-compile toolchain from Linux Development Requirements for Unreal Engine | Unreal Engine 5.0 Documentation (Seems to be right given your screenshot) you need to build the Unreal Editor again (not a full rebuild). It will now create the needed files for UE to recognize that linux is a supported build target.


Kind Regards, Michael

1 Like

Hey Michael, just to say thank you. Yesterday I did build for 5.1 and it worked, I have it now as an option! Thanks!

Thanks :slight_smile: