Download

[Linux] New C++ project spits out a text file. This is clearly a bug

So I’m just starting out and I began with a blueprint project, which was fine, and then tried to make a C++ project. Regardless of of which template I choose, the result of this seems to be the same: I click “create project” and it thinks for a little bit, then Unreal Editor shuts down and it opens a text file in Kate (my text editor) named MyProject.pro. I’ve pasted the first few lines from this file below (it’s a long file). After this, if I try to open the project from the launcher I get an unintelligible error message. Could anyone help me out here? Is this a familiar bug? Using Linux Mint 17.1.


# UnrealEngine.pro generated by QMakefileGenerator.cs
# *DO NOT EDIT*

TEMPLATE = aux
CONFIG -= console
CONFIG -= app_bundle
CONFIG -= qt

TARGET = UE4 

unrealRootPath=/home/fake/UnrealEngine
MyProject3RootPath=/home/fake/Documents/Unreal Projects/MyProject3

gameProjectFile=/home/fake/Documents/Unreal Projects/MyProject3/MyProject3.uproject
build=mono $$unrealRootPath/Engine/Binaries/DotNET/UnrealBuildTool.exe

args=$(ARGS)

SOURCES += \ 
	"$$unrealRootPath/Engine/Source/Developer/AITestSuite/Private/AITestSuite.cpp" \
	"$$unrealRootPath/Engine/Source/Developer/AITestSuite/Private/TestLogger.cpp" \
	"$$unrealRootPath/Engine/Source/Developer/AITestSuite/Private/Actions/TestPawnAction_CallFunction.cpp" \
	"$$unrealRootPath/Engine/Source/Developer/AITestSuite/Private/Actions/TestPawnAction_Log.cpp" \
	"$$unrealRootPath/Engine/Source/Developer/AITestSuite/Private/BehaviorTree/TestBTDecorator_CantExecute.cpp" \

etc. (this goes on for thousands of lines)


This is likely not a bug. This text file is a project file for your C++ IDE to open, and not the Unreal Launcher. What you should do is install Qt Creator with apt-get if you haven’t done so yet (I believe the package name is simply qtcreator, someone correct me if I’m wrong). Once you do that, you should be able to open this .pro file by double clicking on it and compile your project.

This is definitely a bug, the Unreal editor isn’t supposed to just kill itself when you start a new project. I can say that with 96% certainty.

I tried compiling as you suggested, there was some kind of pathing problem though so I edited the makefile in the project directory. I changed this:


BUILD = /Engine/Build/BatchFiles/Linux/Build.sh

to the full path:


BUILD = /home/fake/UnrealEngine/Engine/Build/BatchFiles/Linux/Build.sh

and it… well. It worked for about an hour, generated almost 20 GB of junk data, and then spat out an error. I think it was trying to recompile the editor. Speaking of, I have a follow-up question: Can I just delete everything in the /Engine/Intermediate directory? I think that’s where it put all the junk and my hard drive just isn’t that big.

First, UE4 is not yet officially supported as a platform where the Editor can be run on. It says nowhere it would work fine.

It works because Epic and some good ppl in the community work on it, but its not there for general consumption yet.

Then what you experience as a bug is the same behaviour everywhere, and not a bug. Windows, Mac, Linux. You create the C++ project, the project launcher closes and the IDE starts with your project. The Editor is going to use your C++ code as libraries to present itself and your logic, that must be built first. Fully expected behaviour.

If you want it to work fine you should go try it on Windows until its ready for Linux.

When you delete the Intermediates folder you got to regenerate to project, and it will fill up again when you build the Engine. My Windows build uses around 35 GB, more if it starts collecting backups and asset caches and what not.

All right, thank you. I guess that does make sense.