Download

Linux mint, editor,textures errors...

Linux Mint 17, with the 3dluvre 4.7.5, compilation and start worked as described on the webpage.

I start with this:

Bildschirmfoto vom 2015-04-08 21:52:46.jpg

i imported a jpg and created a new material. Then i edited the material and this happens all the time:
(It works when i attach an constantvector3 to the Basecolor. The Shader compiles normaly.)

Bildschirmfoto vom 2015-04-08 21:51:39.png

i saved all the stuff and shutdown and reopend the project. Now i cant see anything in the contentbrowser. I cant use
the rightclick menu in it and i cant rotate the viewport anymore. It only works move forwards and backwards. Now its completly unusable.
Sometimes the Materialeditor also doesnt show anything at all…

520f64c70799a0b3891c3fadad76074a443ab737.jpeg

the console shows this

a327321d0a81ab934e36e765a1d7bd2183f177a5.png

i started the editor with -opengl4 parameter, but it makes no difference, the result is the same with -opengl and even without parameter.

Is there a workaround to this problems? In Windows, it works normal but i realy want to use Linux because i hate windows and the Epic Launcher anoyes me with his updatebehavior :wink:

Hi,

For the shader issues, try in the console: r.InvalidateCachedShaders

For the Content Browser, in your project’s folder, delete Saved/Config folder and load the project again.

Not sure why this is happening, but it needs more investigation.

P.S. We are going to get the Epic Launcher in Linux too, and it’ll be the same as Windows. :slight_smile:

Thanks. :slight_smile: :slight_smile: That worked.

P.S. as long as i do not need the Launcher to start the editor in Linux i can live with that :smiley:

same problem on gentoo, gtx780.

I switched to fro 3dluvr to epic/master and it shows v4.8. But the problem still exists. The Editor works fine, (and in my opinion its faster now :slight_smile: and the thingi with “every tooltip is a new window in my taskbar” is gone, thanks for that, it was driving me nuts… (and now i miss it…**** :-P) ) until i import an image or a fbx with texure. The import works as expected. Mesh/Texture sho up in the contentbrowser. At this point the Materialeditor does not show the nodes anymore even with a new blank material. When i save the project and reload, the problem with the empty contentbrowser occours.

Same for me!
Hope this will be solved soon

Reload project make some fix but this can’t be solving, because it need with ALL import.
Content Browser window lost UI after reload and i reopen this window for fix this.

Lost rotate viewport camera (RMB) afret reopen project
Don’t find how fix this

But in Play mode viewport’s camera can rotate

yap, same here.

btw, in 4.8 the trick with deleting the Saved/Config folder does not work. :frowning:

“import” bug has solved!