Linux dedicated server missing scripts

Hey everyone, looking to get some feedback on an issue that I’ve been trying to solve for about a week now. So I’m trying to get my dedicated server working on Linux but I’m having some issues when I run my server. The server runs for about 2-3 seconds and with verbose logging on it just spits out a bunch of errors that it can’t find files for a marketplace plugin that I use. Essentially its about 50 lines of missing dependency of /Script/pluginname/file.

After about a day of troubleshooting I decided to build it for windows, works flawlessly. With the same exact config that issue is gone. For windows I tested using the latest Windows 10 update and even got my server to run inside a docker container on server core 2019. If it wasn’t for the fact that I need my server to run in a linux docker container, I would have just stuck with windows.

So far I’ve tried running my linux server on the latest centos docker image as well as ubuntu image. Just for safe measure, I even got an ubuntu vm running on hyper v and all 3 machines are spitting out the same error.

So far I’ve tried:

  1. manually editing the plugins main file to set it to load first thinking that it may be referenced before it was instantiated, didn’t work.
  2. Using this guide as a step by step reference for doing what I wanted to do.
  3. Using this guide as another reference to see if I missed a step. Even tried the step where I throw my server executable inside of the built LinuxNoEditor folder(didn’t have to do this for windows).
  4. Making sure the plugin had Linux as a build target.
  5. I also reached out to the plugin dev who also reassured me that there shouldn’t be an issue building for linux

I’m under the impression I just missed something major as I am completely new to this. I don’t know if there is a magic bullet that will include that plugins scripts inside of my build but any and all feedback is majorly appreciated.