Linux dedicated server doesn't show log information

I’m currently trying to find out how build dedicated servers for Linux and using the ShooterGame provided by Epic as an example. I have been following this wiki (A new, community-hosted Unreal Engine Wiki - Announcements - Epic Developer Community Forums and have successfully built and ran a Windows dedicated server. I have also successfully built the Linux server (on a Windows PC using cross compilation toolchain) and moved it my remote server running Ubuntu. I’m currently running v4.19 built from the source.

However, when I run the following command to launch the server:

./ShooterGameServer -log


The process launches and I can kill the process by using Ctrl+C but I don’t get any information printed to the screen like I did when running the Windows server. I’m also not able to connect to the server from the client on my Windows computer. I’m wondering what the best ways are to proceed and debug this problem?

Regarding the log - unlike on Windows, the server does not open its own log window but instead prints it into stdout (which is a normal behavior for Linux programs). Please run the server from a terminal and you will have its output right in the terminal you’re running it from.

Inability to connect may be caused by multiple reasons: firewall, different CL than Windows client, etc.

Thanks for your suggestion. I should have made mention of this in my original post but I’m currently SSHing in my remote machine and running the server from the command line. Any suggestions on how I can debug this?

Did you manage to get your linux server build working with v4.19?

It looks like I might be having a similar problem: Linux Dedicated Server Issue v4.19 - Platform & Builds - Epic Developer Community Forums

This issue has been fixed and released with 4.19.2 Unreal Engine Issues and Bug Tracker (UE-58073)

My docker container isn’t outputting a log. I can find that my sessions been created in my developer portal but I don’t see any log of this inside of my terminal I ran it from. Why is this, and how can I fix it?

found a solution ?