Download

Linux Compiling and Other Woes...

I am now officially out of ideas … and hereby request assistance from those that have done it before or know how to do it.

What I Have Working:
I have got a game running and compiling under Windows perfectly, this includes a Windows Dedicated Server. I package the project on Windows correctly and compile the Dedicated Server on Windows correctly and everything works as expected.

What I want to do:
I want to create the dedicated server on Linux and then would like to package and compile the game to be used on Linux. This is both for Dedicated Server and Game Client.

What I have tried:
Firstly I tried to package and build on Windows using Clang … I was unable to get it working. I followed this tutorial: Compiling For Linux

Next I tried to Build the Editor on Ubuntu Linux and then do the package and build on Linux … I was unable to get it to even build the editor properly. I followed this tutorial: Building On Linux

I then tried to Build the Editor on Linux Mint and do the same package and build on Linux … I was actually able to get the Editor to Build and Run (see attached screenshot), but it crashes all the time. I am unable to create and open a new project and I am unable to open my current project. I followed this tutorial: Installing Unreal Engine in Linux Mint/Ubuntu

http://www.gobbogames.co/uploads/UE4_Editor_Linux_Mint.jpg

Where to from Here:
So I am not sure what to try next and desperately need some help. I know Linux pretty well and I have been using it since 1997, so it is not a lack of Linux knowledge that is catching me out. Please can someone point me out to a possible solution or series of tutorials or series of steps or just generally some tips to look at. There is so much conflicting information that I feel like I am chasing my tail … if I get it to work, I will document my steps and return it to the community in the form of a wiki page.

I have tried everything I can think of … I hope someone can help.

Thanks in advance.

Hi there :smiley:

I can not help you with packaging on Windows for Linux but If you want to use UE4 on GNU/Linux (GNUX) I might be able to do so.

  1. Which branch did you use to compile UE4? (I can see you use maybe 4.7.x). I wouldn’t recommend using the official epic 4.7 branch on GNUX. That version is quite buggy and does not have all community developed fixes and improvements for the UE4. Read this A new, community-hosted Unreal Engine Wiki - Announcements and Releases - Unreal Engine Forums for more information and use this branch if you have to stay on that branch use this repository https://github.com/3dluvr/UnrealEngine using the 4.7-linux branch.
  2. If you don’t have to use the 4.7 branch consider really switching/using the official 4.8 branch (not yet full released). It contains all fixes so far for the GNUX environment of UE4.
  3. Ubuntu 14.04.02 LTS is the most well supported and if you have used the branch I mentioned in 1. you wouldn’t have problems. On a fresh Ubuntu 14.04.02 LTS I was able to compile without any “issues” with just: ./Setup.sh ./GenerateProjectFiles.sh … Described on the wiki page I mentioned.

If you say Ubuntu, Linux can you please describe your system:

  • Which version of Ubuntu?
  • How much ram?
  • GFX card? Driver?
  • Pastebin of your crash? Just saying crash the whole time will not help.

On #ue4linux there are a couple of people who might help you with your problems.

@Yaakuro: Hi there. Thanks for the information, here is a response to your questions.

  1. I was using the 4.7-linux branch (https://github.com/3dluvr/UnrealEngine) and not the official Epic branch.

  2. My game is currently using 4.7 … but we are still in Alpha … so we could move to 4.8 … I will give the 4.8 branch a try and test it with Ubuntu 14.04.02 LTS.

  3. That is good news … let me try that and get back to you.

  • I was using Ubuntu 14.04.02 LTS.
  • 8GB of RAM
  • I tried an NVidia Quadro 3000M and an ATI Mobility Radeon HD 5730

I am not intending to use Linux for my Game Development … I have a window machines for it … but I want to compile the Dedicated Server and package the game project on Linux for Linux.

Basically I was getting Memory Access Violations and the editor would just crash. I am not going to bother trying again … I will try what you suggested in No. 2 above and let you know how it goes.

Thanks again for the prompt response … much appreciated.

Hi

  • I am not sure how big your project is but 8GB is quite less and that might be one reason for the memory violations. The UE4 on GNUX is not so well optimized for now so it might need more memory. I have here 16Gb and that is what I would recommend to have at least.
  • Did you try to use the UnrealFrontend in the 4.8 version to package and test your stuff? Or did you try to do the packaging in the UE4Editor?
  • Actually these kind of questions I would really ask on AH selecting the Linux topic. I would assume that AH is a better place then the forum, but I might be wrong.

This is the error I get when I attempt to package the project for Linux on Windows by following this tutorial: Compiling For Linux

Full PasteBin is here: http://pastebin.com/u2DbsmcJ

I am also getting this error when attempting to package for Linux.

I was told to open the file and save it as ANSII … but this is pointless because the file is overwritten each time I try to package the project.

Okay … found the issue … thanks to Epic Staff … you guys rock. 8-}

https://answers.unrealengine.com/questions/229428/linux-compiling-and-other-woes.html

So last night I managed to get a double whammy.

Compiling for Linux on Windows:
I have the game packaging and building for Linux on my Windows machine using Clang bu following this tutorial: Compiling For Linux

I am using 4.7.6 from Github and all I had to do was change the encoding of the source files in my main game source project to get it working. I have now packaged for Linux and just built the server for Linux using Windows and Clang. 8-}

Compiling on Linux:
Following the advice from Yaakuro … I re-installed my PC with Ubuntu 14.04.2 LTS and using the 4.8 branch I followed this tutorial: Building On Linux

I didn’t have to do anything strange here and everything is compiling and working and I haven’t experienced any issues so far. 8-}

Next Step:
I will now using the Compiling for Linux on Windows for the next release … but will start looking at moving the project to 4.8 in the long run.

Thanks to Epic and everyone who helped me … you all rock.

Good to hear. Let’s make more games for Linux too :slight_smile:

Okay here is another one … the server works beautifully … except on Ubuntu it binds to 127.0.0.1 by default and not the external IP Address.

Any idea, I think it might have to do with the /etc/hosts file which has my host name linked to 127.0.0.1 and I notice in the console log of the server it refers to that Host Name. Should I change the IP Address in the file or is there a way to force the server to use the external IP Address.