[Linux] Can't drag anything in the editor. From Place tab, content browser, panels or assets


I’ve built UE4Editor for Linux by following this guide step by step:

To better explain what is happening here’s a video:

When I try to drag a panel nothing happens.
When I try to drag from the “place” tab to the viewport nothing happens.
When I try to drag from content browser to the view port nothing
And also when I try to drag the move gizmo in the viewport nothing happens.

I’ve a bit about it and it seems that some of it are known issues that should’ve been fixed in 4.8.
When I built I used the command: git clone -b 4.8 https://github.com/EpicGames/UnrealEngine.git
So I should have the correct version.

I have tried: Rebooting, Remaking and Rebuilding UE4

If it’s relevant i’m on Elementary OS Luna (based on Ubuntu 12.04) and built with clang 3.3.

Thanks for reading

Hey -

What desktop environment are you using? Can you check if you have the same behavior when using KDE or Unity?


Hey -

We’ve not heard from you in a few days and for tracking purposes I will be marking this post as resolved. If you are still having any issues with dragging assets in the editor please feel free to comment here to reopen the post and we will continue investigating.


Hello ,

Sorry I did not reply. I’ve been busy.
I have now tried running Unreal with KDE, GNOME and Unity. I get get the exact same behavior as described in the original post.

Let me know if you need more info.

Ok I have sort of fixed the issue.

I upgraded my from Elementary Luna to Elementary Freya.
This fixed the issue.

Hey -

Considering you mentioned using the 4.8 branch did you use the same branch for testing across all of the desktop environments? Since the 4.8 branch does not undergo the same stability testing as the release branch it is possible that there was an issue with the branch at the time that you build the engine. I have tried to reproduce your issue on the 4.8 branch but have not had the same issue with dragging objects into the viewport. Can you try building the engine using the release branch ( -b release) and see if you get the same behavior in a new project?