[Linux] Cannot build lighting!

I have asked this problem before to no avail. So let me ask again. :slight_smile:
I try to build the level, and all goes well until It does the Lightmass. It gets stuck at 0%.
I was doing this offline and I went. “Maybe I need to be online?” And it started to build fine online.
a couple of days ago it stopped at 0% online and off. This is really getting on my nerves, so
a answer would really be nice. And yes I have opened diffrent projects and loaded one’s that used to build.
I am using Unbuntu by the way. Help this is a major problem!

Hi 94,

I’ve gone ahead and closed your other posts so that all the information is in a single post. It’s better to “bump” a single thread after a few days rather than opening multiple threads with all the same information.

Often when Lighting is stuck building at 0% it may appear that it’s not working, but often this is just the calculation phase of light builds.

What type of scene do you have? Large, Medium, Small?
Do you have a lot of meshes in the scene?
Have you increased the lightmap resolutions of a lot of meshes? if so, try lower lightmap resolutions.

Can you try building lighting in one of the template projects, like the first person or third person template?

If lighting builds here you need to take into consideration some things for your current game that can help improve light builds.

Let me know.



Sorry for making to many posts… Also the scene was originally somewhere between medium and small. I gave up after 12 hours. I tried all the templates… As you can guess they didn’t work either. And let me say there was nothing overtly complex in any of those scenes. (old school FPS stuff.) Thanks for answering.

Okay this one is interesting. I just put all the graphical setting to the lowest they can go. Now it says it built, But when I enter the Level it says all the objects are unbuilt? But when I put it back to my old setting the same old Stuck at 0% problem is back. any ideas?

Ha Ha! It works now for some reason. don’t know how, but it works!

I actually had a similar issue and I couldn’t figure out what was going on. (I had a project in 4.7.6 where the lighting would not build past 0% I let it sit for about 9 hours and it never went up, I am using a small project which usually takes about 10 seconds to build the lighting) I tried adjusting the graphical settings but that didn’t work. After trying a number of different things I copied the project files into a new project file. That didn’t work either. But immediately after that I closed UE4, Epic Games Launcher and changed the map name (Through my Mac’s finder) to a new map name (Before I had it at Map_Beta I changed it to Map_Charlie). And it builds fine now.

The main difference between my issue and 94’s was the templates were building for me it was only the one project.

I hope this helps anyone else who is having this issue.

I’m having the same issue on Mac (UE4 4.8.1). Closing and opening the editor seems to help.

I just had the same issue on 4.11, and restarting the editor fixed it for me as well. Thanks!

I ran inot the same problem while experimenting with Hierarchical LOD. The BUILD ALL command had built the LOD meshes and materials but they were not showing in the HLOD subdirectory. I SAVED ALL manyally and ran BUILD LIGHTING and everything worked

For me restart of computer, and restart of launcher didnt work.

LinuxMint 18.1 on Version 4.14

Even when I want to build a completely empty Level, it gets stuck

They made a bug entry or whatever about this in another thread I started.
Don’t know if anything has come of it. Lighting will not build offline - Platform & Builds - Epic Developer Community Forums

I encountered this issue after opening a project started in windows on linux.

For me the solution was to delete all levels builtdata - close the project, open it and rebuild all levels.

Also, delete all generated folders in project. Intermediate, built, etc


@grimdee try my answer below… issue may be caused by several different issues, not just win<->lin