[Linux] Autosave fails when using -SaveToUserDir flag

In our deployment UnrealEngine is deployed to /opt/UnrealEngine-Release. Users do not have write permissions for that directory, since we have shared workstations. So we are using the -SaveToUserDir flag when launching. However, when that flag is used UnrealEngine fails to autosave with this error:

“The filename ‘/home/HOME_FOLDER/.config/Epic/MyProject5/Saved/Autosaves/Game/VProdProject/Maps/Main_Auto1.umap’ is not within the game or engine content folders found in ‘/opt/UnrealEngine-release/’”

We have also tried using the -UserDir= flag (in place of the -SaveToUserDir) and pointing to another directory with no spaces or “.” in the path (aside from the file extensions) that a user would have write access to, however the same error occurs.

Manually saving works as expected.

We are using UnrealEngine 4.26.1 on CentOS 7.

Any help in getting autosave to work would be greatly appreciated.

Steps to reproduce:

  1. Launch UnrealEngine with the -SaveToUserDir flag
  2. Choose Film, Television, and Live Events
  3. Choose Virtual Production
  4. Enable Raytracing
  5. Create Project in “/home/HOME_FOLDER/Documents/Unreal Projects”
  6. Once the project loads, save it once manually
  7. Make some changes to the scene so that it’s evaluated as dirty
  8. Wait for the Autosave to start
  9. An error message will show up with the error message above