[Linux]Alt-drag reset rotation and location

Just built UE4 using instructions from this site A new, community-hosted Unreal Engine Wiki - Announcements - Epic Developer Community Forums, wanted to play with some meshes I already used in Windows version, nothing fancy. Problem is, when I alt-drag mesh to duplicate it, the rotation and location resets itself to 0 just as if I clicked cpy-paste or duplicate (not sure if those should reset it too, but I don’t remember doing it ever, because alt-draging was so awesome)
Sorry If this is duplicated, but I didn’t found anything similar through my quick search

Hey -

When you made a clone of the repository by following the steps in the link did you use the 3dluvr repository or the Epic Games repository (replace 3dluvr with EpicGames in the “git clone…” step)? I would suggest using the Epic Games repository as there is no way to know what changes may have been made to 3dluvr’s personal repository. IF the problem is still occurring while using the Epic Games repository then we will further investigate this issue.


Just built EpicGames version, behavior is the same.

When you created a copy by Alt-drag were you using a BSP brush or a blueprint or something else? Do you have the same behavior when duplicating other assets in the same way? Were the meshes created on Windows and do you see the same reset issue with meshes created on Linux? Anytime I attempt to use Alt-drag it will create the copy with the same rotation as the one I copied it from and the location is set based on where it was dragged to. Let me know if you’re still having an issue and if there’s any additional information you can add.

Hi ,

Just a heads-up that 3dluvr/4.7-linux is our community repository where fixes to many issues have been made that could not make it into epic/4.7 in time.

Since 4.8 is now in preview, everyone should be switching to it anyway as all of our changes from 3dluvr/4.7-linux are in epic/4.8. :slight_smile:

First I noticed it when I was using imported fbxes, but it was the same even with sample stuff (the orange chairs and table).
I don’t remember if it was the same with BSP.
It was always on new project, not the one I was working with on Windows.
I deleted the whole folder just in case and now I’m cloning promoted branch. When I’ll be finished with building it, I’ll update you if it is working for me then.
I can’t due to this: [Linux][4.8.0]UE4Editor crashes on loading (72%) - Platform & Builds - Epic Developer Community Forums

Hey -

It’s my understanding that when you use Alt+drag to duplicate an object that its rotation is reset and it moves to the origin (location resets to 0,0,0). I have not seen this behavior on the EpicGames built engine or the 3dluvr engine. Alt+Drag for me is the gloabl shortcut to drag the window that currently has focus. If I use Alt+Shift+drag it will duplicate the object and move the camera along with the object but will hold it’s current rotation. Let me know if this works for you or if there’s something else that I’m not doing that you are.

I just successfully built and ran Editor from promoted. This behaviour appears after importing meshes both with alt-drag and shift-alt drag.
Before I import meshes everything is fine.
Tried with meshes done on Windows and those from Linux.

When I reload project it works as it should again BUT there’s nothing in content browser and I can’t rotate things with rotation tool (I can rotate it in transform panel). Move and scale works fine.

EDIT: Built 4.8 instead of promoted. It is the same way there plus there’s the behavior like in this link, so this was not directly caused by crash. Although It seems to be resolved in promoted.
EDIT2: I built master. The behavior is same as in 4.8, probably was the same in promoted then but I didn’t notice.

After some messing around I can write the summary:

If I use default assets only, everything is fine.

If I import anything and even quit without saving, after opening the project again:

  • i can’t rorate thing with the rotate tool

  • there’s nothing in content browser (I can browse paths, but nothing appears)

  • rightclick lookaround is not working

  • alt-drag works.

If I import anything (not placing imported asset inside scene) then alt-drag issue appears on meshes that are already there.

Hey -

I was able to reproduce the issue with the right click not functioning and the content browser being empty after importing an FBX and have reported this bug (UE-15462). The content browser can be worked around by going to Window->Content Browser and choosing a new content browser window which will show all the project assets.


How about alt-drag after importing things? Did you notice anything like it?
I was importing assets made in blender. Probably that is not important as I was trying with FBX 7.4 binary and 6.1 ASCII, and result was the same. But MAYBE that is significant. here’s the file i used to test it, so you won’t have to worry about it if you don’t have blender onboard :wink:

Using Alt+drag is set as a global Linux command on my machine that will drag the application window that currently has focus. Using the Shift+Alt+drag method gave me the same results I mentioned before (creates and drags a new instance and moves the camera while dragging).

I changed that for ‘windows’ key. Is there anything else I can provide to help diagnose this issue?

Built promoted recently and alt-drag now works OK :slight_smile: