Linux 4.8 Bugs

Some linux bugs from 4.8

  1. When importing FBX, uv’s do not import correctly. It re-scales the mesh uv’s to fit between 0-1.
  2. Overwriting a fbx doesn’t actually overwrite the vertex colors (drag and drop a file from file browser and it asks to overwrite, but doesnt completely overwrite)
  3. Delete keyboard shortcut doesnt work in the editor

Hey Gibbz-

I checked the the delete key functionality and found that this has already been reported (UE-14143). I’ll need more information to understand the other issues. For the first one (FBX uv’s) can you explain what you’re doing and what you’re seeing when importing the FBX. I tried importing a FBX who’s unwrap is outside the 0 - 1 space. UV channel 0 maintains the unwrap as imported from the modeling program (3DS Max in this case). Below are the settings used during import as well as what my UV’s look like in the editor. Let me know if you’re seeing something different or if my process was different.

Cheers

Doug Wilson

Ok, think ive figured out whats going on.

  1. On windows the default import setting was to overwrite vertex colors, on linux its set to ignore. Shouldnt this always just be replace as default?

  1. When I import using “Generate Lightmaps UV’s” which is default, it overwrites my channel 0 uv’s. I have tested this on windows with the same file and it works fine, so this looks like a linux only bug.

And with lightmap disabled it works…

  1. Also noticed the Project browser does not remember/save the projects that are outside of the default unreal projects path, which is a bit of a nuisance (same on windows if i recall).

  2. And that flashing tutorial button top right! Will that ever be fixed! :smiley:

also noticed changing objects between levels via the “world outliner” doesnt seem to work on linux.
Right click > level > move selection to current level.
The mesh disappears from both levels into who know where…

Hey Gibbz-

I’ve tried changing my settings as you suggested and the UV’s for my mesh are still appearing as in the screenshot I posted before. Additionally, when you have “Generate Lightmap UVs” checked true it should produce the lightmap as UV Channel 1. Based on the screenshots you provided I don’t see Channel 1 in either case which is strange. If possible could you send the asset that isn’t importing correctly?

Yep, thats whats happening, the generated uv is overwriting my channel 0 with the lightmap. Hence its losing my uv data.

link text

Yep, thats whats happening, the generated uv is overwriting my channel 0 with the lightmap. Hence its losing my uv data.
link text

Hey Gibbz-

After checking on a different version of the engine I too saw the same behavior and entered a bug for the lightmap generation (UE-16516).

Cheers

Doug Wilson

FWIW BaseEditorPerProjectUserSettings.ini has Ignore as a default vertex color import option on all platforms. Could it be that you changed this on Windows in the past and it got saved with your preferences?