LINK : fatal error LNK1104: can not open 'ucrt.lib'

Hello,

Got this error when i try to package projects for windows with installed plugins activeted (like substance or true sky).
When i uncheck them, every packaging works fine. I have tried to reinstall visual studio, but same problem ocur…
(i’m not developer)

Thanks for your help

Hello aubertaxel,

Could you provide the full log file for one of these failed packaging attempts? You can find them in your project’s directory under Saved / Logs. Do you have “Nativize Blueprint Assets” activated?

Hello Matthew,
“Nativize Blueprint Assets” is not activated.
You can find here the log output : link text

Thanks

I’m not sure that this is exactly related to the Linker error but it seems that you may be using an invalid file format for your project’s icon picture. That’s told by this message:

[2017.03.08-17.55.13:858][633]LogSlate: Only BGRA pngs, bmps or icos are supported in by External Image Picker

Do you have the Windows 8.1 and/or Windows 10 SDK installed? This seems to be a general error that people have outside of UE4 as well so it may be related to the Visual Studio installation or SDKs that it relies on.

The problem is that i can not package whith first person template (for exemple). The Engine package the project without error only if any “installed” plugin is activeted.
Yes windows 10 SDK is installed :confused: I have tryed to reinstall it but don’t work at all ;(

As the issue is only happening with these plugins installed, I would suggest reaching out to the plugin developers for further assistance. I’m not familiar with true sky but I do know that Substance has a responsive support team that should be able to point you in the right direction. You can find their UE4 forums here: UE4

I have had this before when making changes to my installation of visual studio (in my case when removing parts even though they are unrelated to UE4). Regenerating the visual studio project files fixed it for me.