Linear Limit size can't be lower then 0.1

When using a linear limit size lower then 0.1 in a Physic Asset it is the same as setting it to 0.
I need to use something like 0.025 for my case. I’m using a chain with several bones and Linear Limit Soft, it currently either stretches way too far or way too short because of this bug. It is possible that the bug also exists for angular limits and things like physics constraints components and their linear limit.

Hi Davision,

Unfortunately, I’m having a difficult time determining a significant difference between .0025 and .1, do you have an asset where this change becomes apparent?

With 0.025 you will get no linear movement at all. Despite 0.1 already being a very small value the Linear Soft Limit will make it appear much bigger when enough force is applied. To recreate it you can just Ctrl + Right Mouse drag on a bone in the Physic Asset editor. At best do it while the root bone is fixed, so simulate only bones below. In my case I have a chain with 40 bones so the difference between 0 and 0.1 is very obvious.

Do you have a sample asset I could test this with? I have been unable to see the difference on my end thus far.

Here is the asset: https://dl.dropboxusercontent.com/u/2650899/ArmsPhysics.zip One arm has their bones at a 0.9 linear limit and the other at a 1 linear limit. 0.9 can not stretch at all while the 1 limit stretches super far.

If UE4 would let me change the linear limit values of bones at runtime that could also be a solution for my case. Then I can make it 1 when I need to stretch it and set it to to lower then 1 when I need no stretching currently.

I’m still not seeing the same error, What specific bone/constraint do you target when you see this occur? Additionally, Are you setting the Linear Limit Size on all bones or just a few? Are you only limiting the motion on one axis, two, or all three?

Hi Davision,

We have not heard from you in several days. I am marking this as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information.