Download

Line trace set forward vector max

Hello, I have a problem with moving an emitter spawned(attached) at the line trace hit/ or 1000 units forward(get forward vector multiplied by 1000)

I can move it horizontally but can’t move it closer to the character. I mean, I can spawn it next to the character, it will hit the collizion and appear on the floor(will go through it if I move the camera down) but I can’t move it forward or closer from there, I can only move the spawned particle horizontally or up/down

When I spawn it and it doesnt hit a collizion, when I look down It just ignores the floor collision and goes through it, probably because the line trace goes 1000 units forward.
Is there a way to set the 1000 only as max and be able to move the particle closer/furher?
I feel that it also has to be somehow related to collizion
Please halp! Thanks!

Please halp!

Turn on debug line on node so you can see trace and debug.

Issue is probably collision settings

Thanks man, what do you mean by collision settings? The particles goes through every mesh, and all meshes have a “block all” collision setting

About debugging - the line does not go through collizion, however, the emitter goes as it is “spawn emitter attached” in order to be able to move it