Line and Sphere Trace stops hitting Projectile after a few hits


I’m trying to set up two Input Events; One which pushes a large projectile away from my character and one which pulls it towards my character. But for some reason after a few successful line traces (used to push away) and sphere traces (used to pull towards) both traces stop hitting the projectile, but not necessarily at the same time. I can’t figure out what’s causing it, the traces just start returning false with no hit info. There is no hit event on the projectile, it’s basically a large sphere which I want to bounce around like a ball.

Push Away (Line Trace):

The Event GunFired just plays a montage and sound on the clients.

Pull Towards (Sphere Trace):

Any help would be appreciated.


LOD settings for the projectile:

Do you have any LOD on thing you’re trying to hit?
If so make sure to disable and try then.

Thanks for the reply. Can you tell me where I can find the LOD settings for it please? I found an Include setting for HLOD on the Sphere and Sphere Collision. Is that what you mean? If so, I’ve just tried disabling that but it didn’t solve the problem.

HLOD is Hierarchical LOD:

I mean that you can go into static mesh properties and there is LOD (Level of detail) that changes your object and it may be reason why you can’t hit it when it’s far.

I have added a picture of the LOD settings to the question. However I can stand right next to the projectile and it still doesn’t hit. So it doesn’t appear to be anything related to distance.

I’ve just worked out what’s happening, but I still don’t know why. I shot the ball to push it away (which worked) but when I tried to run forward I couldn’t because the collision component was still in the original location even though the mesh had moved. I shot the collision component and the mesh on the other side of the screen then moved. But the collision component then seemed to move at some point because I could walk forward again but not being able to see it I couldn’t work out where it went. The actor has a Sphere (mesh) which is a child of a Collision Component. Any idea why they’re not moving together?

“The actor has a Sphere (mesh) which is a child of a Collision Component”

Are you moving only static mesh or whole actor?

Just the mesh. Add Impulse requires a primitive component reference as the target. So I don’t know how to apply it to the whole actor. I’ve tried applying it to the sphere collision as it’s the parent but then nothing moves at all.

Try to attach Collison to Static mesh and

I’ve now set the collision sphere as a child of the mesh with physics enabled on the mesh. I’ve deleted the Projectile Movement component and added a physics material instead to make the ball bounce. It’s now working as I want however my blueprint run a line trace for objects with the object type set to “Projectile”. The ball’s parent class is Actor and there is no projectile movement on it, yet it still gets hit by the line trace. Why does it still think it’s a projectile? I expected to need to change the line trace.