Limit on Teleporting to Empty Actors?

Maybe it is something different with how the objects involved are located, obstructed, or configured, or the assets that comprise them?
Or their collision settings?

What’s wrong with this BP?

Each of the teleports, except #5, are working. The BPs are basically identical. Locations 2 - 5 are Empty Actors. Teleporting to #5 might work sometimes, but usually doesn’t. The others are consistent.

I get the same result, even if I manually enter the xyz location data for #5.

EDIT: The event is firing. Adding a #6 teleport actor works consistently as well. #5 is still a problem.

Each of those objects (2-5) is an Empty Actor. They were simply dragged into the scene. I have moved, and deleted and replaced #5, all to no avail. Each actor has a default root component with a billboard.

Good point on collisions. I could check that. But that doesn’t account for the pawn not teleporting there.

I also have an automated process (demo mode) that cycles the pawn through these locations. Same result. #5 will fire, but no teleport.

Another strange occurrence: The above issue with #5 occurs on the computer at work. On my home computer, this issue occurs with #3. The event fires, but no teleport.

I’m filing a bug report.

The issue is actually the slope of the landscape at the target location. If the actor mesh will collide with the landscape (or any other geometry), the Teleport will not work.

And the two computers were not in-sync.