Download

Limit CPU+GPU usage by default?

I have a somewhat bizzare question: I have my computer (i9 10850k/RX580) plugged into a 420W UPS which is plenty enough for 99% of the time as nothing makes sustained 100% usage of both CPU and GPU. Even latest gaming is fine.

With the exception of the Unreal Editor. When compiling shaders, both CPU and GPU often go to 100% and the UPS starts beeping.

Question: is there a way to limit the usage of both (or maybe just one of them, preferably CPU), so it doesn’t reach 100% at the same time? I have tried AppTamer for Mac (it’s a dualboot Win10/Hackintosh) and similar Windows utilities but the issue is, UE4editor spawns the ShaderCompilerWorker processes that are not limited. I know I can disable Realtime but that doesn’t always help. I have already set Power Saving mode in BIOS, not enough.

Any tips? Thanks!

Inside UnrealBuildTool
enable the developer options( by setting the developer options to true) & setting local jobs as you desire.

Try Process Lasso free software, adjustin the number of cores to shadercompiler.exe

Hi, thanks for the suggestions. Problem with shadercompiler is there are arbitrary number of them spawned, so you have no control about how much CPU gets used, even if you limit each one of them.

I have ultimately solved the issue with disabling turboboost, MCE and manually limiting PL2 TDP to 125 instead of 250W. The system runs cooler, smoother AND FASTER (in benchmarks, Unreal AND games) as it doesn’t throttle as often. There’s no point in spiking to 5.2 GHz when all it does is consume 2x as much energy and jittery performance.