Download

Ligting and lightmaps going for a toss in mobile preview

Hey guys,

I am using Unreal 4.7.3 and I am facing a weird issue when I am previewing my level in Mobile Previewer or on the Mobile Platform.
But first, a couple of screenshots:


This is the level when I am viewing it using the SM 5.0 previewer in the editor.


And this is the level when I preview it in the Mobile Preview and on the Device (Samsung Galaxy Note4 + GearVR)

Now my first, obvious question is what the hell? Why am I getting this discrepancy in the output?

My second question is a little more involved. Again, two more screenshots for your benefit:


SM5.0


Mobile Preview + Device

If you look closely at the ES 2.0 image, you will find a lot of “banding” happening in the lightmap, giving the overall impression that this is a really low resolution thing. How do I get rid of this?

I think much of this is fixed if you’re using GL ES 3.0 (feature set should be similar to DX3D 11). Problem is, I think you need to build the actual source from GitHub to use it (in addition to the extension pack for Android as well), which I don’t know how to do (nor have the data bandwidth to spare).

Hi mdhananjay,

Have you checked theMobile Development Guidelines to make sure you’re not using any assets, lights or post processing effects that will not perform well on mobile? It might have some useful info, if you have not.

Hi wittlief,

I have checked that thread, and in fact I have followed all of the settings from the Mobile Temple example you guys have provided, and am pretty much stumped at this point. All my lights are static, I have no post process effects on, in fact I don’t even have a Post Process Volume in there.

Plus, I have made sure that TemporalAA is off in the project rendering settings.

Any clue?

Hey Zodiark,

Thanks for chiming in; my problem is that I need this to work on the gearvr and I’m not too sure how well the GL ES 3.0 will play with that…

Awwwww yisssssss! Found out what the problem was. I had put in a Skylight actor and had forgotten to turn it to Static instead of stationary. That solved the colour difference problem. But the “blockiness” or pixelation of the Lightmaps is still an issue.

Ok so, now we come to the other issue, which is the strange “blockiness” of the lightmaps. Surprise, surprise, they are compression artifacts. On investigating further, I turned off Lightmap Compression, and voila! Clean lightmaps everywhere. But the consequence was that my project size exploded four times, which in their defense, Epic states will happen. And apparently I am not the only one with this problem; this dude was/is also facing the same problem.

Any advice here? Is there some way to set the compression quality of the textures to a higher setting, especially for lightmaps?

To anyone following this thread:

Okay, so I found some more clues to point me in the right direction: Modular assets. Apparently large surfaces with uniform shading tend to have compression artifacts displaying prominently in their lightmaps. Lightmaps may have those artifacts in general, but when you have some sort of a pattern going on, it tends to cover the compression artifacts. I found an excellent resource about this whole issue over here.