Download

Lights turning off after building lighting

I have a project with static lights which seem to turn off after I build the lighting. My work around has been moving the lights, so they are not built. Unbuilt lights seem to look good in the scene. I packaged a version of my game and forgot to move the lights, and everything is dark in that scene as you can see in this video: Absolution: A Vampire Tale, playthrough and Postmortem - YouTube

I thought building lighting was supposed to make the lighting look better after being built. Anyone know why the light simply turn off in my scene in this project?

A few things to check

  • Check if allow static lighting is enabled in the prj settings
  • check if a level is set to being a scenario level and that this level is loaded.
  • Occasionally a light actor can get corrupted so try to place a new static light, build lighting without changes then save and package. See if that light worked.
  • Check your static meshes have light maps and they are enabled with the correct id in the mesh settings, not the mesh build settings.
  • Add reflection captures.

Building lighting isn’t a difficult thing. There must be something you’re doing in your level preventing light maps being saved.

Thank you for the reply. My static lighting is enabled in the project settings. I’m not quite sure what a scenario level is, could you explain that suggestion more? I create this level myself, if that answers that. I’ve deleted and added actors several times, it does not seem to make a difference. I can confirm that some of my light maps are messed up, and I’m working on that, but that should not affect meshes that have correct light maps, such as my characters, correct? The baked lights don’t shine light on anything, and I have to unbake them to get light. There are reflection captures in the scene, and that does not affect the lack of light.

Lighting scenarios store all lighting baked but it’s unlikely you have one.
I would suggest you create an empty test level with only one static light in it and a few of your meshes in a new project. Then bake lighting and see if it works.
You may have accidentally made some changes to settings. You could also try to rename your /config folder to reset all settings. If that fixes the problem then you know it’s one of the settings messing it up.

I ended up turning on Force No Precomputed Lighting in the World Settings. This seems to turn off all baking or something like that. It worked for the purposes of this project. I’m giving up on this one for now, since this was only for a game jam, which is now over. I’m sure I’ll run into this issue again in the future, but that’s future me’s problem.