Lightning needs to be rebuilt after i just built it (iOS)

Hi, currently I’m working with an IPad Air and I try to run different UE projects on it. But at the moment I got a really strange bug: I built the light (Build → Build lightning only) and after it was done I hit Launch → All_iOS_iOS on [PC Name]. After this was done i ran the project on the IPad and it told me (in the top left corner): LIGHTNING NEEDS TO BE REBUILT (206 object(s)). I didn’t got it and thought i’ve done something wrong, so i built the light again and launched for the IPad again. Result: Same warning, but “only” 27 object(s) left to be rebuilt… wuhu. Would be nice if i could get this down to 0 and that’s where i need your help please, because i have no idea what i am doing wrong.
Additional i got another bug when building light, but not everytime, just like every 4th attempt to build: After the build is done, my sceen is much darker than it should be, probably caused by the fact that UE deleted my skyl sphere and some spotlights.
I hope you can help me, thanks in advance :slight_smile:

Well I created a new level and copy-pasted everything… works now.