Download

Lightmass error 0xc000007b

Hi everyone!
Im having this error each time I try to compile the lights on my game, and its driving me insane…
I’ve been said that it might be because a bad graphics card, but i have a gtx980, i have reinstaled visual c++ redist like one hundred times, cleaned and validate cache on swarm agent. Deleted temporal files on user/appdata
And i ran out of options… any hints to try to fix this?

Thanks in advance

Check out the UE4 AnswerHub:
https://answers.unrealengine.com/questions/topics/0xc000007b.html

That’s all abour UE4 Launcher and paragon launcher, my error is on Ligthmass, paragon works perfect, engine works perfect :frowning:

On that search is all about starting errors on Paragon game or in the engine itself, both works perfect on my computer, but not the LightMass, that the only thing failing, anyways i searched trough all of those answers.
Reinstaled the engine entirely, check my graphics card drivers but its updated to latest version.
Uninstalled and reinstalled again all versions of visual redist, for visual studio 2013 and 2015, cleaned the cache of swarm agent. cleaned all files inside appdata. i really dont know what else can i do.

I’m sorry to hear that that didn’t help.
If you haven’t already, please make a post on the answerhub.
If nothings else, it will help draw more attention to the problem you are having.

i really appreciate that :slight_smile:

I have already posted on answerhub, but i had the same responce regarding paragon and unreal engine launch problems.
but anyways i have followed those steps and get a log with dependency walker.
Im leaving the Txt log file as an atachment.

Regards.

Any news on this? i being looking for possible answer and searched almost the entire internet without any fix :frowning:

Briefly looked at it outside of Unreal.
Came across the same suggestions - update .NET, run as admin etc.

Have you tried the Dependency Walker mentioned here?
https://answers.unrealengine.com/questions/12975/unreal-engine-wont-launch-error-code-0xc000007b.html

Hey, I had the same issue.So, here’s what worked for me.
I had a d3dx9_43.dll file in system32 which was apparently a 32-bit version of the file.I found that out by running a dependency Walker check on the UnrealLightmass.exe that is generated as cache.
So, I downloaded a 64-bit verson of the file and replaced it in system32 folder.That’s it.Flew for me.(I have also spend hours and hours for someone to tell me a solution but sometimes you gotta figure out things yourself.)

link: d3dx9_43.dll free download | DLL‑files.com

@sj_agrwl Showing that a suggested solution does actually work will hopefully help people in future.

Thanks for that :slight_smile:

tl;dr :: To get everything working, I had to reinstall windows.

Here’s was a problem that caused me a lot of time and stress. The Dependency Walker returned null results (i.e., all the right dependencies were in the right place). I reinstalled the c++ redistributable, dotnet stuff, and ue4. By process of eliminating, I came to the conclusion that my Windows files possibly got corrupted. I am not surprised by this… in the past, when Windows tried to install updates, I would unplug the computer from the power outlet to stop it (LOL).

Since my important files are backed-up, when I decided to reinstall Windows, I said to my self, “to hell with it…” and I completely erased my hard-drive (i.e., all bits were set to 0). It feels nice to now have a clean, blank slate. However, I’m sure that most people won’t want to reinstall windows. Is it is possible to replace certain Windows32 files without needing to reinstall windows?