Download

Lightmass crashing-Array index out of bounds

The title says it all, a scene that used to build now crashes out with this error. Anyone know a like;y culprit or where I should start looking? Thanks

<None> === Lightmass crashed: ===
Assertion failed: (Index >= 0) & (Index < ArrayNum) [File:d:\build++ue4+release-4.18+compile\sync\engine\source\runtime\core\public\Containers/Array.h] [Line: 610]
Array index out of bounds: 7616 from an array of size 7616

0x000000006AB73FB8 KERNELBASE.dll!UnknownFunction ]
0x0000000039E65E54 UnrealLightmass-ApplicationCore.dll!UnknownFunction ]
0x000000002D101A8B UnrealLightmass-Core.dll!UnknownFunction ]
0x000000002D092E98 UnrealLightmass-Core.dll!UnknownFunction ]
0x00000000B06AEF14 UnrealLightmass.exe!UnknownFunction ]
0x00000000B06BE054 UnrealLightmass.exe!UnknownFunction ]
0x00000000B06B3B8B UnrealLightmass.exe!UnknownFunction ]
0x00000000B06C58A4 UnrealLightmass.exe!UnknownFunction ]
0x00000000B06FD863 UnrealLightmass.exe!UnknownFunction ]
0x00000000B07204DA UnrealLightmass.exe!UnknownFunction ]
0x00000000B077EC25 UnrealLightmass.exe!UnknownFunction ]
0x000000006C1B1FE4 KERNEL32.DLL!UnknownFunction ]
0x000000006E7CEFB1 ntdll.dll!UnknownFunction ]
0x000000006E7CEFB1 ntdll.dll!UnknownFunction ]

You might be running out of RAM

No, I’ve been watching that in the task manager. It crashes 5 secs into doing the lighting build. I re-imported my scene through Datasmith & left out a few meshes I had added in previously by hand. That seemed to clear the light build part of things. Thanks

When lightmass crashes always start with clearing your lightmass cache.

Thanks, I will remember that for the future.

It happened again & clearing the swarm cache fixed it. Thanks for the heads up!

could you please tell me how to clear the lightmass cache ?

Open the swarm agent by double clicking the swarm agent icon in the task bar (…after it was building lighting. The icon might not be there if you just started the the editor). In that window there is a menu “Cache”. In that menu click on “clean” and then “validate”. Then check the “Log” tab if it was successful.

Thanks guys, this solved it for me. Clean and Validate Swarm… Ram not part of the issue. Thanks.

This helped me too I was using GPULightmass and came across similar error. Glad I googled this one quickly!

i have the same problem and i tried to clear the cache in the swarm agent and it still didnt work i would like some help i have been working on a game for 5 months and it was time to build it
Thanks!

You most likely are running out of memory. So you need to reduce your lightmap sizes. Start with foliage if you have it or terrain.

Are we talking about system RAM or video RAM? Thx!