Download

Lightmap UV are overlapping by 2.1%. Please adjust content - Enable Error......

HI All

Error: UV are overlapping by 2.1%. Please adjust content - Enable Error Coloring to visualize.

How do I enable Error Coloring to Visualize please.

Narg

Click onto the “build” dropdown menu -> there you can find it :slight_smile:

THank you

Narg

Needs Documenting

This needs to get into the help file and the general documentation.

I will mention it in the documentation improvements so that it gets add :slight_smile:

I enabled color coloring - and it still says to enable it!!!

Error coloring only shows when you build with Preview or Medium light quality settings. Anything higher and the error coloring is disabled.

If you’re still getting overlapping UV errors and the auto-generated method isn’t working you’ll need to correct the issue with your UVs in your modeling program. UE4 only repacks the texture UV based on their currect seam splits and does not cut or split seams. This could be the issue you’re seeing.

If you’re not sure post a screenshot of your lightmap UV.

Of course it does, because you still have the problem in your geometry. The error message tells you what is wrong (you have overlapping UV mapping for lightmaps.) Then it tells you what you can to do see where in your geometry this overlap happens, if you want to (enable error coloring.) But you still need to actually fix the wrong mapping!

The lightmap texture coordinate channel for each object must not overlap or wrap. If you can’t generate a proper lightmap texture coordinate channel in your modeling tool, you can have Unreal Engine generate a new texture coordinate channel for light mapping in the Mesh previewer/editor.

Can we please add this to the documentation? I’ve been doing Light Builds using Production Quality, and I always wondered why the error coloring didn’t show up. Thank you!

It’s on my list of things I want to do at some point when re-visiting some of those pages, however, that may be a ways out before I really get a chance to due to my other priorities right now. :frowning:

i know its a bit late, but just want the search engine users know: Sometimes, like if the overlapping UVs are 1-2%, you can fix that by Override Light Map Res up to 128.

king regards,
Sam

If it’s a few percent and you don’t notice any lighting artifacts, it’s safe to ignore the error.