Lightmap errors on Static Mesh

Hi,

i’m working on my first assets for the UE and i have problems with the light map uv’s.

I tested different unwraps, the latest is on the picture. i cut off all pieces and give enough space between the uvs.

What i have to change in the uv’s for the lightmap generation?

Hi AndrijaK,

I’m a little confused by your UV screenshot. I can see that you’ve got a second UV for your lightmap (UV Channel 1) with the circled area but you’ve got the area marked “Ignore.” There shouldn’t be any overlapping UVs in your lightmap otherwise there will be some issues with your lightmap texture.

Looking at your first image, it’s also a little harder to tell if that is a smoothing group issue vs a lightmap issue. If you change the light mobility to Movable (Dynamic), is the issue still there? If not, we can start looking more at the issues with the lightmap UV. It’s also a bit hard to read the settings that are in the details panel on the right in your second image since the resolution is smaller. If you post anything with settings can you use a higher resolution image?

Since you did ask specifically about generating a lightmap in UE4 you can take a look at our newly created Wiki tutorial for this process: A new, community-hosted Unreal Engine Wiki - Announcements - Epic Developer Community Forums

Thanks!

I read the wiki, and all paramters like Lightmap Coordinate Index is set to 1 and so on.

The ignore overlapping uvws in the picture are the other boxes in the backround.

The box in front from pic one has the unwrap in the red circle.

Change to Movable has the same result,

The box has one Smoothing Group for the hole Box.

You have some stuff split off that shouldn’t be–the rounded corners can be a part of the other polygons.

Also, make sure your lightmap resolution is high enough.