Lightmap. Black lines appear where geometry is

Helloo so I’ve looked through a lot of the questions on lightmaps but nothing seems to work. I think I’ve set it up correctly. Second uv map, set to use lightmap coordinate 1, set to 128 resolution to test. I seem to be getting black lines where the geometry actually is. It’s all set to one smoothing group and the uvs for the highlighted section is all connected together so I’m all out of ideas and I can’t seem to find it on here. :frowning:

Hello PsychicFreak,

If you would link me screenshots of your lightmaps, as well as your details window in UE4 of your geometry and where you are assigning your lightmaps.

Thanks,

Logan

Hello PsychicFreak,

I have not heard from you yet. I was wondering if you were still experiencing this issue?

Thanks,

Logan

hi sorry. I’ve been away from home for the weekend.Here is my lightmap. It’s not final but I tried to follow the ‘rules’ as much as possible from the docs.

Is there a specific part of the details window you want to see? It’s pretty large so I’d have to crop a few screenshots together. Also, I have no idea where I’m assigning my lightmaps. Where could I find that information? I’m fairly new to unreal 4

Hello PsychicFreak,

It appears as if you have clean geometry and your lightmaps look fine.

If you would link me your .fbx then I can test this out within a test project.

It could be that the smoothing is causing this ore the seam you have in the middle of your geometry is causing this.

Thanks,

Logan

hi here’s the fbx. Dropbox - Error

Hi PsychicFreak,

I was able to reproduce this issue in UE4.

I am going to link you our lighting troubleshooting guide as well as a guide that gives a great, in-depth, explanation on how to set up lightmaps for UE4 and how they are intended to work.

Link to Troubleshoot :

Link to Light Maps,

There are a few things you can do to increase the calculation of your lightmaps.

1.) Min Lightmap Resolution,
2.) Engine Scalability Settings,
3.) Amount of Illumination on the object.
4.) Project Settings > Rendering > Generate Mesh Distance Fields

Have a look at the documentation and try and see if any of these are a viable solution to your project.

Thanks,

Logan

Cheers. That gives me a good starting point. Thanks for looking :slight_smile: