Lighting trouble from Chief Architect to UE4

I was trying to digitally recreate my apartment and took a break to test how it would render in UE4. I ran into too many lighting issues so I decided to start over with a simple test hallway.
Again the bake (production) is blotchy with other errors. I’m just having far too much trouble with this to figure out on my own, so I’m hoping someone here can help me.

I drew some walls, added doorways and windows in Chief Architect and exported as 3ds (later with roof for light leaking) and imported in Blender.
Here are some things I did for the hallway test:

  • left the meshes alone and just exported to fbx
  • removed some faces obscured from view (chief creates layers for the surfaces), which also clears unneeded lightmap space.
  • made a new hallway mesh by snapping to interior/exterior corner vertices
  • merged some pieces together
  • kept pieces separate but removed doubles; all imported faces are triangulated and grouped faces are separated (maybe for material purposes)
  • reset origins of meshes then reposition them in UE4
  • imitated the design with the static meshes in the Starter Content/Architecture folder
  • created BSP in the shape of the hallway

When I import the fbx, I uncheck combine meshes to keep the pieces separated, and disable lightmap generation when I create them manually (which doesn’t make much difference except in one case)
I’m just using a spotlight and a directional light+exponential height fog plugged into UltraDynamicSky (both lights stationary).

The first two images are after creating manual lightmaps with different scales and the last two images are after I adjust most of the lightmaps to 128/256/512 but also let ue4 create lightmaps (I also adjusted the material but the black floor spot was already there).
The first image also contains “some” mesh cleanup but I’m a bit fuzzy on the difference between those two because I took the pictures several hours ago.
You’ll notice a black line in the middle of them all, that seems to be because the faces of two different meshes intersect there. Another thing is corners, they always have that weird shading (with/without AO)

The difference between these and the other tests are very minimal, lightmass gives visible seams and blotchyness slowly goes down by repeatedly doubling lightmap size. Modifying this mesh, remaking the UVs, rebaking everything to see how it went is just really getting to me and I don’t know what’s working here. Do I just keep turning up the lightmap to cover stuff up, or does modifying the mesh help visually?
Also somethings seem to transition through LoDs while I’m close to them or further and I assume that’s because they’re visually in different locations but share the same origin point that’s closer to some areas than others.

So does anyone know how to export from chief architect to get into ue4 or if you use another CAD program, does it use intersecting faces and if so, what do you do?

My guess is that your geometry has issues, for example there’s no reason for a diagonal issue like that without a weird polygon there. That’s probably showing up in your lightmap UV’s as well. Make sure you have no overlapping faces, make sure that your lightmap UV’s have as few seams as possible and try to combine some parts that don’t necessarily need the whole UV space, like some of the walls can be combined and you can probably combine all of the wall edging.

Do you mean like remodelling to work for UE4? Look at the walls with the doors; are you saying to create merged vertices with a loop from one wall to the next to the door frame to the other side of the wall and etc? Also with any corners that contain intersecting faces? Because as I said, it’s double-sided and the vertices go from point-to-point and room-to-room, meaning nothing really to connect separate-but-connected objects, such as the walls.

You don’t have to weld all of the vertices together, but the lighting system in UE4 will process things by each mesh. So the more things you can attach together the better the result will be. For architectural stuff it’s best to split things up only when you can’t get enough detail in your lightmap. If you have to set your lightmap resolution on a mesh really high you’ll need to split it up.

As far as modeling goes, the vertices should line up, at the corner the vertices of the walls and the ceiling/floor should be in the same space. You don’t need any 2-sided meshes or outward faces unless you’re using the Sun for lighting in the windows. If that’s the case then you shouldn’t use 2-sided meshes and instead model the outside surface which will help block the light and prevent lightmap bleeding.

It could also help to troubleshoot if you can post a screenshot of your lightmap UV’s so we can see if there’s a problem there.

You’re talking about a particular mesh’s lightmap, right, as in “the” trouble mesh? Because if you are, there isn’t any.That line in the middle that I specifically mentioned is essentially two separate cube meshes intersecting at the corner, and the only ways I can think of dealing with that kind of thing is to merge the meshes and delete edges then merge and recreate faces or boolean them together.
Actually, after viewing the model, unmodified, it seems that’s NOT from an intersecting face; one cube ends at a corner and the next snaps to the side, so a boolean wouldn’t work there. Could I upload the .3ds file that I initially get and you show me what goes on from there?

I’m not familiar with CA but that black line in the corner I get that with Sketchup models imported into Blender. What happens is Blender turns the black edge line into geometry, or maybe SU does that? Anyhow, I have to delete them in Blender then the corner is clean. Something to look into maybe?
Also some of your issues are not enough light or low GI settings - maybe adjust the light or .ini file?

I meant to upload this image as illustration but forgot then didn’t:

Here is the model exports from chief to blender to ue4 (3ds>blend>fbx). I scale the 3ds file 2.54x in blender then create a second uv map for all pieces then export to ue4.
No idea what you’re talking about but sketchup doesn’t do this unless that’s just the way you model (like bsp, with multiple intersecting boxes).

This is how I model for UE4 in SU (interiors), no overlapping corners as you get light leaks. Where you see black lines, the edges in SU, Blender turns that into geometry sometimes, not always - seems to be a bug.