Download

Lighting studying - Koola's Scene Interior Day

Hi everyone,

I m studying the lighting in Unreal Engine, and I’ve an issue.

To learn, I downloaded the Koola’s scene : Lightroom_Day, available on a marketplace.
I tried to have the same lighting :

  • I used Koola’s meshes
  • I tried to copy/paste the light, the fog,exponential fog, everything !!!
  • I checked 50 time the world settings, etc…

At the end of this experience, I’ve 2 issues :

1/ first image in attached file - Lightmap

You can see, my shadow on the floor is in too low resolution. However, it’s exactly the SAME meshes, with same lightmass settings ( lightmap : 32 ). Why it’s clean on Koola’s scene, and blured on my scene ?

2/ second image - the lighting

I don’t know how Koola does to have this nice global illumination. I’ve the same settings ( i tried to copy paste the post process too… ), but it’s clearly different. Koola’s lighting is more natural, and beautiful.

The only real difference actualy is the Unreal version ( Koola’s scene was in 4.9 or 4.10 and I’m in 4.12 )
Maybe the lightmass.ini too, but I don’t know if it’s really the solution…

Do you have an idea ?

Thanks,

Hi.

First thing, you need to re download the scene. I have made several update and now the lighting setup is simplier and you don’t need to modify the baselighmass.ini to have good quality.

Second thing, I override the mesh lightmap resolution in editor (in the detail panel, go under Lighting, Overridden Light Map).

Hey Koola :slight_smile:

Thanks for your answer !

I downloaded again your scene, and i repeated the same way :

  • export your mesh
  • set exactly same post process, sunlight, Lightmass protal, Reflection capture, fog and exponential fog ( setting AND orientation )
  • set same world setting, progect setting

And I ve still difference. In the first image, you can see the difference between me ( left ) and you ( right ). The only way to have a similar scene with you, it’s to add in post process a tone scene color, but you don’t use it.
And for to have a real comparaison, I ve disable he post process on this screen. Conclusion ? the issue exist with or without the Post process !

The second problem, is a texture : You can see on a second picture, the left material are very more blurred than your right material. Your material is more sharpen, and more contrasted. I use the same compression method, sRGB, but I don’t know what is the difference.
I tried too copy/past your materrial UASSET, same result, blurred for me.

Do you have an any for this 2 issues ? ( Koola or another people, i accept all suggestions ^^ )

thank,

I think it’s because I use the filmic tonemapper (r.TonemapperFilm 1) and the Tonemapping sharpen (r.Tonemapper.Sharpen 1 or more).

How do you set it in editor ??

the console isn’t available only on a packaged application ?

You can set it in editor in the “Output Log” window (Window -> Developer Tools -> Output Log).

Thank Koola, it’s better !

You can see the attached file, it’s more natural. I’ve still a small difference with you, but it’s better !

Do you have an idea for this small different ? your scene is still more natural.

Hi, How do you set Tonemapper Sharpen, Tonemapper Film and other console variable settings per project? It seems all this settings by koola work when the project koola provided in the marketplace is opened. Is there a way to set this per project instead of entering this everytime you open a project in the output log? or is this done with a custom ini file?