Download

Lighting needs to be rebuilt

After deploying to my phone, I keep getting a “lighting needs to be rebuilt (2 unbuilt objects)” error up in the corner. I rebuild the lighting, and it still shows up.

It is also appearing during PIE too, now, which is weird. Perhaps it’s my level, or something within blueprints…I don’t know. Does anyone have any idea?

*edit - are there any folders that need to be deleted (akin to the intermediate and cookediphone/game folder in udk)?

I believe it was due to having a light in the components for the player. It worked fine on PC, but on mobile it didn’t show up/had that lighting issue. After taking it out and rebuilding the lighting, the error went away.

You should note the error will appear again if you move a light.

Right…but I wasn’t moving any lights or objects. I would build the lighting, deploy to mobile, and then test it out with the error saying it needs to be rebuilt.

Even not moving the character with the attached light, it still produced the error. Oh well, it’s fixed now. Thanks though.

i am getting this error on a pc after putting an object in an environment, how do you actually rebuild lighting???

From the toolbar, select the “Build All Levels” button and it will rebuild the lighting as well as any meshes that need it. :slight_smile:

Or you can select the dropdown button right next to the Build button, and choose “Build Lighting Only”

Thank you, that fixed it. I just got this today and i am not a dev :slight_smile:

Just a creative director. Nobody is responding to my project on other forums, so i will have to learn how to build it myself haha. Or at least a walk around map with oculus and leapmotion support to get the first 50k.

i put it here aswell, so we will see what happens

https://forums.unrealengine.com/showthread.php?51329-ROYALTY-VR-Project-experience