Download

Lighting issues on my static mesh! Please help!

Hi guys, I made a house in 3ds max, imported it as a static mesh. So I changed the Light Map Resolution to 2048 and generated an unique UV with the limit spacing = 5 and Max. Stretch to 0.1. Then I generated the UV. So then I changed the Light Map Coord to 1. But this is my result:

My UV:

Whats wrong with my Lighting? I just don’t want those ugly bugs in on the wall.
Thanks for your help

When you make the whole building a single mesh you get very little space for each UV island, as you can see in your UV layout. Split every floor(and every side of every floor if possible) and remake the UV’s with a bit more attention.

Sorry I’m not so familiar with Lighting and Mesh-Stuff. So can you please tell me how to split the floors and what do you mean with a bit more attention?

You essentially just need to break your building into PARTS instead of trying to import it all in one go as one object.

So try separating your walls and floors apart so that they’re on their own, and import them separately (then align them together in UE4 again).

So you mean like I export in 3ds just the walls, just the floors, etc. and then put all together back in UE4?

Yep, thats exactly it. Export separately, reassemble in UE4 like lego.

Just so you know though, the generate UV’s in UE4 isn’t very good. So even after you do all that and generate unique uv’s for each floor/wall, you might still have shadow problems.

You can try it first to see what happens, but its recommended you create your own lightmap UV instead.

You can do this in 3DS Max fairly quickly:

So I made this now, It looks slightly better, but I have those bugs:

Please help!

Hi,

What’s you’re lightmap resolution set at? The default on import is 32. This may need to be increased to get rid of some of the shadow artifacts you’re seeing here. Can you also post a screenshot of your UV layout since you’ve redone it.

Thank you!

Tim

The Lightmap resolution is at 1024 on every wall. The UV of one wall is looking like this:
3c48abc3455c3aff3a6f375cbb0920b3ffeb0006.png

Your UV is not really good, that’s why you have those bugs, you have to redo your lightmap. If you don’t want to care about lightmaps, try to use LPV.

This looks like you’ve used the Generate Unique UVs in UE4.

If so, do this again but instead use the option “Layout using 0 channel.” This will give you better results without having to have such a high LM resolution.

Give this a shot and let me know how it turns out. If it’s still giving issues please post another screen shot with that new UV layout.

Thank you!

Tim

So I made this, but same issues with this lightmap:
ab0abcff450dd39d1f0540e4a5d60b66d7ebb7e1.png
And what is a LPV?

Your UV islands are too close together. They will bleed into each other. Give it more spacing.

Its a “Light Propagation Volume”. You basically put it around everything that should look nice :smiley:
Kind of like the lightmass impotance volume it draws special attention to certain parts of your level…
Havent worked with them yet, so maybe otehrs (incl. the UE4 documentation) might tell you more about them…

Cheers,
Klaus

I can’t change the spacing between it when I use “Layout using Channel 0”. And with A new channel and then limit spacing to 2, it will not affect my scene and the lightning issues are there anyway. I can’t find those LPVs in the Volumes list…

You need to enable them first.
https://docs.unrealengine.com/latest/INT/Engine/Rendering/LightingAndShadows/LightPropagationVolumes/index.html

What to do?

actually your last attempt to UV’ing looks ok-ish. you could try select all of your faces on the map and scale them down locally all at once. that way you’ll generate some space between the islands which should help with the shadow bleeding and at the same time keep the overall proportions.
bit of a hack tho :wink:
from what I read and experienced so far it’s also a good idea to have polygons facing in the same direction connected together if you can.
because right now it looks like you just separated every single face and then triangulated.