lighting is not equally represented across platforms

Hi

There seems to be a massive discrepancy across different platforms regarding lighting/brightness and strangely uvw behaviour. For example, i’ve just created a project which displays the same as the editor in the desktop package, but the same file packaged to html5 or mobile is really dark and badly lit. In the html 5 version the uvw’s are also badly deformed for some reason.

The final packaged product needs to be an exact replica of what is viewed in the editor regardless of the platform being packaged for.

Cheers

Michael.

Hi 3d Illusions,

It would probably be best to post some screenshot comparisons and the platforms you’re trying to develop for.

There are a number of reasons that would cause lighting to look differently on different platforms. For instance, HTML5 and mobile will use lower end settings or different rendeirng paths that can make things look different. So with this in mind, you cannot have them look exactly the same. A lot of post process features are not supported or are limited depending on the platform you’re developing for as well.

A good place to start would be to review the information in the documentation here under the General Development section: https://docs.unrealengine.com/latest/INT/Platforms/Mobile/

As for the UVs being screwed up it may be best to post that in the AnswerHubbug reports section with clear steps to reproduce the issue and screenshots to show the problem more clearly.

I hope this helps.

Tim

Hi Tim, thanks for coming back to me.

I appreciate what your saying. As a programmer myself (boring intranet and web apps), I don’t like the idea of having to read through endless documentation to manually re-adjust parameters or implement alternative solutions when the limitations and suggested workarounds are known. Surely it would be better to have these steps automatically implemented in a non-desturictive way (maybe by creating a duplicate project with the ammendments for that platform) during the packaging process, or maybe if this is not feasalbe have a pre-packaging function that checks for known incompatibilities and recommends fixes, with an apply “yes or no”?

For example, if exposure bias is increasing lighting in the editor, but is not supported in the platform being packaged for you might get a message like "post processing exposure bias is unsupported in the target platform, increase all lights/self illumination by x%? Yes/No.

I’ll post screenshots later though.

Cheers

Michael

I should probably mention i’m producing architectural and interior visualisations, where the only thing that matters is decent graphics which are consistent across platforms.

if anyone would like to try out the files to see the issues, the html5, windows packaged version and editor project files can be downloaded here:

Cheers

Michael.

I took a quick look at the project and if you change the rendering preview level to the that of Mobile/HTML5 vis the Settings > Preview Rendering Level you’ll see that it looks as it should for HTML5 and the supported features.

I see the UV issue going on with the floor. I feel like this was reported before, but I’ll have to look and see. If not, I’ll put a ticket in and post back with the ticket number for reference.

-Tim

Thanks for taking the time to have a look Tim.

Cheers

Michael.

No problem. Looking at this further the texture you’re using in your material is a non-power of 2 texture which means that it will be clamped when the UV extends past the 0,1 space. After scaling the texture back down to a 512x512 rather than the 720x720 everything is working as I would expect. Something like this won’t show up in the Mobile Preview mode on your desktop PC in the editor because it will still use a higher precision where it’s not clamped.

The documentation here references this: Textures for Mobile Platforms | Unreal Engine Documentation

Thanks Tim, did you need to scale the texture down outside of unreal, in photoshop for example, or can it just be amended in the unreal image properties screen?

Great advice Tim, i’ve modified all textures to be power of 2 and they now tile flawlessly.

One other problem i’m having is getting reflections to work. The lights captured from one reflection sphere seem to be appearing in all surfaces rather than what is captured from the nearest reflection sphere to any given surface. I’ve followed instructions to disable ambient cubemap in the post processing volume, and removed specular inputs on the materials in question to no avail. Also turned off screen space reflections by setting to 0.