Download

Lighting difference in adjacent surfaces?

Can anyone tell why this happens - or has experienced something similar?

The two floor surfaces have the same lightmap resolution and are roughly similar surface area but the one on the left is darker than the one on the right.

768f3007a0bb529178176420a1f787a5168cb255.jpeg

Because of how lighting is rendered, separate objects will have slightly different indirect lighting, which is an issue for planar meshes like what you have. To fix it you would need to combine those two meshes into one.

Like darthviper107 said, it’s because of the light each of your Meshes receive. The room on the right side seems to be lit from several windows. The room on the left has only one hole in the wall, at least it looks like it.
This means basically the room on the right side gets more “Light-Input”, therefor it is brighter on the whole surface, at least that’s what I think to understand :'D

If you don’t wanna combine these Meshes you “could” (I say could because there’s no magical trick to solve these problems) try to fight this with some tweaks in the world-settings.

There’s a Link to the Lighting-Section and if you scroll nearly to the bottom there’s the part called "World Settings)
https://docs.unrealengine.com/latest/INT/Engine/Rendering/LightingAndShadows/Lightmass/#lightmasssettings

If you set the “Indirect Lighting Quality” in your Project to 2 or 3 it might soften the difference a bit. But be careful with this, the time you need for building the light is increasing with it.

Also maybe you should add 2 more Lightmass-Portals between the rooms. It might also help but I’m not really sure about that. (Does anyone know more about Lightmass Portals inside of a building between rooms?)

I’ve seen projects with lightmass portals in door openings too. That could help too maybe!

Actually no, the reason it’s doing it is because the meshes get processed individually, there’s some smoothing done to improve the results without using more samples but it can’t take the whole surface into account so you get a slightly different smoothing result when it’s done on just the one mesh: https://wiki.unrealengine.com/LightingTroubleshootingGuide#Shadow_Seams.2FShading_Differences_with_Indirect_Lighting

Thanks for the input - I’ll check out the links you provided.

If you use “basic preset” for light building, change it to medium or high.

+1

You need to combine the meshes, otherwise whatever trick you use there will be a difference. Only case this is negligible or non-noticeable is if you have dynamic lighting.