Download

Lighting build failed. Swarm failed to kick off.

Got this error today after working on a project with no errors for hundreds of hours, troubleshooted every solution available online to no avail. Tried deleting every item on the map, disabling firewall, checking if 2 instances were running at once but nothing. Are there any other solutions to this and is it really necessary that this connects online to build your map? I really don’t get it and am currently contemplating reinstalling Windows :confused: Any help would be greatly appreciated!

Try to rebuild UnrealLightmass (open *.sln file in Visual Studio, in Solution Explorer right click on Programs->UnrealLightmass, build (or rebuild)). I had this error and rebuild was the only thing that helped me.

Thanks for the reply man, where exactly is the sln file? Ah programming, I only do level design and have no experience with that. Any advice on how to generate the file? I can use another PC for now.

You don’t need any programming skills to build the ue4.
Go to https://github.com/EpicGames/UnrealEngine (you’ll need github account (free), otherwise you’ll get 404 error message) → Clone or download → download ZIP. Unzip to some folder.
Install Microsoft Visual Studio (https://www.visualstudio.com/ → Download Community 2015).
In the folder with unzipped ue4 run Setup.bat file
GenerateProjectFiles.bat
Double-click on the UE4.sln file
In Solution Explorer right click on the UE4 target and select Build (it’ll build entire engine, including UnrealLightmass). Wait ~40min. After that you’ll get working copy of the latest ue4 version. Run …\Engine\Binaries\Win64\UE4Editor.exe, choose your project, and everything should work fine.

Thanks mate, you’re a legend!

Thanks! That solved my problem!

THIS WORKED FOR ME:

If you’re using 4.10 or later you will need to have the VS2015 dependencies installed.
You can download the Visual Studio Dependencies from Microsoft’s website:

VS2013: Download Visual C++ Redistributable Packages for Visual Studio 2013 from Official Microsoft Download Center
VS2015: Download Visual C++ Redistributable for Visual Studio 2015 from Official Microsoft Download Center

That link is broken. What are we suppose to be downloading? Also yes I’m resurrecting this thread because my lighting keeps failing and I have no idea why.

Which link is broken? If you’re referring to the GitHub link, you’ll need to connect your Epic account to GitHub to view the content: Unreal Engine 4 on GitHub - Unreal Engine

X-post from another thread: This has been an issue for us when we import meshes from Revit via Datasmith that have overly-long filenames. Changing the **display name in the World Outliner **to something shorter often fixes this. We found this out the hard way by going through and deleting meshes until we found the culprit mesh. Best practice is to rename things before bringing them in via Datasmith but sometimes we don’t have the luxury of that.