Light turn off when not watching it in my First Person BP project


Why the light (from a fire particles for example) turn off when my hero dont see it ?

Hi skeleton60:

Maybe you need to expand the size of the bounding box of your particle system to prevent no longer being rendered when leaving that area of particle system influence.

Thanks for the tip :slight_smile: i didnt know there was a bounding box for that, my particles system may have no bounding box at all.

The missing bounding box is what
causes the particles to disappear when
the emitter is off-screen, since GPU
particles require a fixed bounding
box. To enable this, in Cascade, click
in the black background (not on the
emitter), and in the Properties tab
search for “bounding”, click the
checkbox for Use Fixed Relative
Bounding Box, then up on the toolbar,
click the Bounds button to see the
bounds on screen. The size of the box
can be modified by expanding the
dropdown in Properties and modifying
the Min/Max.

In the level, you will now notice that
the particles will only disappear when
the edges of the bounding box are
Quote from