Download

Light shining thru walls

I have a pair of static meshes in a level. The first is a warehouse and the second is a store room inside the warehouse. The store room has a point light inside of it. For some reason, the walls of the store room mesh are not casting shadows. The light inside the store room is showing up on the outside floor as if the store room wasn’t there. The store room mesh has all the shadows enabled and it’s double-walled with polys for both the exterior and interior and everything has been carefully lightmapped. Is there a way to fix this?

Did you build your lighting? Make sure your lightmap resolution is high enough, if it’s too low then it can illuminate pixels that are so bit that they bleed across walls and their illumination will extend beyond that.
Also, make sure the walls are actually thick, not just a plane facing inward and a plane facing outward, there needs to be separation between the surfaces.

I found the problem. The mesh was fine. The light itself didn’t have the shadow enabled.

But I do have one more question. I can’t seem to get the automatic exposure to do anything. Does this not work yet?

What are you wanting to do with Automatic Exposure? This is working and can be set via the Post Process Volume.

I have a post process volume defined and the exposure enabled AFAIK, but you can walk in from a bright outdoor area into a darkish room and nothing happens. Does this not work in PIE?

This should work by default in the viewport/simulate/PIE unless disabled, because I always turn it off when I’m not working on my final look for a scene.

Possibly check your engine scalability settings and make sure everything is set to EPIC. Otherwise, the post process will be disabled if below a certain setting with this.

I checked and the settings are on Epic. Not seeing anything. As a simple test, I enabled the lens flare to see if it would show up. Got nothing.