Light map Problem

1st post here and I’m hoping someone can help me with a problem I’m having with an asset I’ve started to bring into unreal from 3dmax. When I build lighting, the shadows are all screwed up. I’ve checked created unique lightmap, and set resolution to 512 and lightmap index to 1. Does anyone have any ideas what I need to do to fix this? Any help would be very much appreciated.
What it should be:


What I’m getting:

Hi Lovingsaskia,

Welcome to the forums and the UE4 community! :slight_smile:

Can you post a couple of screen shots of your UV layout for the lightmap? You can do this in UE4 by opening the static mesh editor > clicking the UV button in the tool bar > and selecting the drop down to show UV Channel 1.

While the generated Lightmaps work in most instances, the layout of the of the UV channel 0 for the texture will determine some of what goes in here. The generated Lightmaps in UE4 will not combine or separate any UV islands/chunks. It will only repack them.

Post a screenshot of your UV channel 0 and channel 1.

Thank you!

Tim

Thanks for your reply. I think I’ve got to the bottom of the problem, Me!. Made a noob mistake by bringing the whole top part in as one whole combined mesh, therefore had too little resolution and too small uv islands. Splitting my mesh down further to see what I get and will post my results.

Ok, banging my head against the wall now. Tried breaking the model down into components, but still got lightmap errors. Help?
b94adb77c92016ecb62c2e6819bb7d4411ffa34b.jpeg
a6aa6d83af011e329783396cbb43ae89c8f31fac.jpeg
29dcb11e3350c43acc4744c157c822f0e41faa36.jpeg

Seems like you are using UV channel 0 for lightmap and UV channel 1 for textures? I believe the inverse should be standard practise.

Yes I agree, you have your UVs switched, Channel 0 is for textures and channel 1 will automatically be used for lightMap. I had an object once that I tried to swap the lightMap assigned UVs in Unreal on because they were backwards, and found that even when I re-assigned the numbers in the details it didn’t like that. It’s not a clean practice anyway, best to fix in your modeler.

Your texture map UVs though from my perspective are not the most effective use of UVs either though. For a shape like this I would probably start with a projection map of the front of the Arch. This will eliminate any edges between the column and arch portion but i have an odd theory of texture mapping and saving space. In textureMap UVs I allow my UVs to overlap for mirrored images (As Long as they are not going to get a texture on them later in Unreal like a splatter for instance ). This practice essentially doubles my resolution, and is the technique I would use in visual effects for years to do the same, and does not give any texture map errors in Unreal software. You only receive errors for lightMap overlapping UVs.

-Dv

Yeah that was a rapid unwrap whilst I was fault finding, but what tells you my uv’s are switched as far as I can see my light map is using channel 1?
Oddly baking seems hit and miss at the moment. One minute I’ll import and bake and it will look ok, then bake again and the problem will be back.

The top image you posted it says showing UV channel 0. The second image says Showing UV Channel 1.

The top image, which is channel 0, and used for texture map, is consistent for what I expect a lightMap UV channel to look like (channel 1).

The lower image which is channel 1, is more consistent with the layout someone might try for textureMapping UVs.

Usually when UV mapping, I am more meticulous about my textureMap UVs, and then use AutomaticMapping to generate the UVs for lightMap (which it looks like you used for the first set, channel 0).

these essentially need to be swapped. But in Maya or your software of choice, I would look for overlapping UVs. I would make sure that the min LightMap resolution is high enough to support small details in the lightMap. I believe there are two settings for this in the model, and from what i remember i had to sync these up.

Now even though you use Automatic Mapping to get your UVs sometimes problems occur still, but I don’t see anything in Channel 0 that would imply a problem. So i’d try swapping these channels or re-assigning, whatever works best for you.