Light extremely bright when looking at objects

I’ve got a problem with a flashlight I’ve equipped to my player character. As of right now, I’ve literally just connected a spotlight to the player and made no adjustments to it and I’ve searched online on how to solve this problem, but I can not find anything about this. If anyone knows how to remove this bright glare when looking at objects, it would be really helpful.

(Can’t post the image for some reason, so here is the link

Maybe Eye Adaptation?

Try to switch it off, go to the PostProcess/Camera settings and find AutoExposure. Set the Min and Max Brightness to the same value to turn it off.

It’s already switched off for me

Hmm, strange, do you use a PostProcess volume? Maybe the bloom is too high?

Do you have a problem with the amount of light being reflected from surfaces? Then maybe you want to check your material settings especially the Roughness value, try setting it to a bit higher value.

I don’t have use a post process, but I saw this exact problem online a few days ago and I just can’t find it again when I need it

Have you checked your material settings? And do you experience this with all types of material, or just with certain ones?

It’s all materials, depending on how close you get to them. As you walk close to a wall for example, the light will get brighter and brighter and that’s what I want to disable.

Can you please post a screenshot of one of your material setups?