Download

Light build quality is lower after splitting the project into two levels.

Hello All,

I’m separating my apartment project into 2 different levels using level streaming. One will be the living area and as you walk down the corridor it will load in the bedroom areas. I have set it all up so but when i build the lighting in one of the levels it comes out okay ish but i notice its has lower res shadows, some artefacts creeping through where it didn’t before and the quality overall just looks lower (See examples below)

Building before as one single level :

Building after splitting into two levels :

There’s a big difference in the quality.

I have all the settings set to high. The baselight.ini file has high settings which are the same as when it built correctly. The lighting quality is set to production. The scalability settings are at their highest yet it comes out different.

I’m using GPU to build the lighting and i notice that before i separated the project into two levels it would build the main umap and as it would build i would see it calculating the number of indirect lighting bounces at 20. When i build one of the levels now it’s calculating 3 bounces i think. Is there something i’m missing in the settings?

FIXED:

I had to duplicate the original Umap and work within that. It only worked if i duplicated. If i created a new level and copied stuff over it wouldn’t work.

Try StatGPU in the console. There’s other quality / resource evaluation features too. Look 'em up in ray tracing pages in the doc.

I’m not sure it’s that I think it’s something to do with it building with default settings. I’m using this to build the lighting is it something to do with this command?

You can use command line to launch the editor and bake lighting to save GPU resources for GPULightmass, especially video memory.

  • Engine/Binaries/Win64/UE4Editor-Cmd.exe “path o\your\project\yourproject.uproject” -run=resavepackages -buildlighting -allowcommandletrendering -map=/Game/Maps/MyMap.umap
  • Remember to replace Content with Game in the umap path

See above. Before the “Radiosity pass” would say 1/20. Now it will only do 1/3. All the settings are the same in the file. I have 20 bounces of indirect lighting set but it will only process 3 when i try to build the light.

Pretty sure that the problem is it’s building with the default world settings of 3 indirect light bounces hence why the build quality is lower. Not sure why it’s building like that as i’ve set the world settings higher in unreal. Does anyone know of a fix for this or even why it’s doing that?

Your lightmass settings are stored in the “world settings” of your persistent level. If you make any changes then you need to make them in both persistent levels. Persistent level is the one which is always loaded and contains all sub levels. This is where the world settings are stored. If you have everything in one level, then this is the persistent level.

So once you copied your old level and then deleted the doubled up content you also copied the world ssettings. When you made a new level and copied the content from the other level you didn’t copy the world settings. Hope that makes sense.

It helps when you look at it from the games perspective. Lets say you have a very detailed small indoor level and then you go outside to a very large less detailed outdoor area then you will need different lighting settings. That’s why they are stored per level and not project wide.