Lift physics - bug?

Hello,

When i activate lift, it somehow swallow character mesh…

When lift moves from up to down, its ok.

What i tried:

  • using lift with custom and basic mesh too
  • using lift movement in actor, in level BP and in matinee too

Could someone help me please?

Anyone with similar problem?

Bump
I tried it also on 4.10.4 engine and got same bug… (used 3rd person template map and basic cube as lift)

  • i noticed same problem when lift moves from up to down, but it is much less seen

  • when that lift moving up more than ± 2m/seconds and character jump, then he drop under lift…

Bump
Still nobody? I can award someone who can help me with this…

Have you tried visualizing collision volumes(pxvis collision) ?
It may be that the physics is a step behind the rendering.
You could try enabling CCD in the physics options for either the lift and or the player.

HTH

I tried CCD to every component before but it didnt helped…
Now when i reloaded project, “SWEEP” boolean helps and character is not more stucked in lift and dont drop after jump, but that actor affected with “sweep” is not moving when im standing on him…

edit: now i noticed same bug in UE epic tutorial Setting Up Lifts | Unreal Engine Documentation

  • in video when lift is moving up and down, it not colliding well with characters mesh… so i bet jump wont work too

I believe Sweep is used to make the object stop on collision, At least that is how I am using it.

I could test my “lift” if you give me an idea of how far yours travels.

BTW which version are you using?

Maybe you need to enable sub-stepping in the project settings.

HTH

Yep sweep should stop actors movement (now i read doc),
Im using currently 4.11 and tested it also on 4.10.4 engine…
Substepping i enabled and tried to change all its values…

If you could test that lift i will be very grateful… im trying to solve this over 20 hours googling and engine digging but without success…

btw i dont understand exactly what you mean with that “idea of how far yours travels”, but my lift is moving up ±15 meters over 2 sec (if i tried very slow lift, then i can jump, but in faster lift i cant and that stuck render looks bad)
(im using only basic nodes…very easy - tick and SetActorLocation)

I tried using my lift to accelerate the player quickly, It worked fine once.
My lift seams to give a large impulse to objects on it as it accelerated my character really fast, I probably have to tweak some physics settings before I could do a proper test.

I think i know what you mean, in character movement disable something like “Z velocity” (or impart base velocity Z, im not at home so i cant check it right now) which is added to jump if you are moving on lift… and after that you will get proper physics

Bump, still not found solution

Bump… Still nothing