Download

Lidar Point Cloud runtime c++ link error

Hi,

I have problems compiling a small test c++ function that uses the Lidar Point Cloud Plugin, here is the code:

TArray<FLidarPointCloudPoint> MyPoints;
MyPoints.Init(FMath::VRand()*50,100);
FLidarPointCloudAsyncParameters ioppa=(true,nullptr,nullptr);
ULidarPointCloud *MyLPC=ULidarPointCloud::CreateFromData(MyPoints,ioppa);

this throws a LNK1120 “unresolved external symbol” error.

 unresolved external symbol "public: static class ULidarPointCloud * __cdecl ULidarPointCloud::CreateFromData<struct FLidarPointCloudPoint const *>(struct FLidarPointCloudPoint const *,__int64 const &,struct FLidarPointCloudAsyncParameters const &)" (??$CreateFromData@PEBUFLidarPointCloudPoint@@@ULidarPointCloud@@SAPEAV0@PEBUFLidarPointCloudPoint@@AEB_JAEBUFLidarPointCloudAsyncParameters@@@Z) referenced in function "public: static void __cdecl UMyLPCTEST::LoadLPC(class ULidarPointCloudComponent *)" (?LoadLPC@UMyLPCTEST@@SAXPEAVULidarPointCloudComponent@@@Z)
  UE4Editor-LIDARComponent_TEST.dll: [LNK1120] 1 unresolved externals

Using the CreateFromFile function works fine, so I think it could something related only to CreateFromData.
Any hint welcome.
Rob

Have you found any solution? I’m stuck on the same error.

Hi, should be solved on 4.27 (sorry for the late answer).